Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Mac with OS X Lion I'm editing a bunch of photos in Preview via the Finder, and any that haven't been edited for a while pop up with an annoying choice of Unlock, Cancel or Duplicate. Well how can I select the whole folder and unlock them all?

share|improve this question
    
In general it doesn't bother me, it's only noticeable when operating on a bunch of files that you haven't worked on for 2 weeks. –  justinhj Apr 14 '12 at 15:22
    
I can't test it, but maybe the annoying info is stored in some extended attribute with the files. Can you do a ls -l@ on such a photo? –  slhck Apr 15 '12 at 8:04
add comment

3 Answers

put files into one folder and run

sudo chflags -R nouchg path/to/directory
share|improve this answer
1  
I tried that but the annoying popups persist. touch *.jpg works, but I still get a bunch of annoying "autosave could not save document". I've just set the autosave date to 1 year to shut it up. –  justinhj Apr 14 '12 at 15:49
1  
-1, obviously it doesn't work, and the uchg flag has nothing to do with it since it's been available much longer than the Auto-Save feature of Lion. –  slhck Apr 15 '12 at 8:01
    
Sure works for me. –  John Gardeniers Aug 17 '12 at 13:58
add comment

Even if don't use Time Machine, the preference in "System Preferences > Time Machine > Options > Lock documents" is still valid, and is enabled by default :S So, uncheck this to stop this behavior.

If it is locked in the same way downloaded files are, you can unlock them by removing the ._* files. Do the following in terminal:

cd /path/to/parent_folder
find . -name "._*" -exec rm '{}' ';'

it will ask for the administrator password. If you received no message after entering the password, it worked and your files should be unlocked.

NOTE: Be careful with the second command as it will delete all the files matched by the find. You can chech which files will be delete by running only

find . -name "._*"
share|improve this answer
1  
damn that's a dangerous command to type, if you make a mistake, boom :) –  justinhj May 18 '12 at 4:55
    
@justinhj You can replace rm with echo and see what it'd remove. –  slhck May 18 '12 at 8:56
    
@justinhj I'll add a note to the answer. –  svallory May 19 '12 at 2:35
    
@slhck this also works for downloaded files :) –  svallory May 19 '12 at 2:35
add comment
up vote 0 down vote accepted

Using the command line tool 'touch' works. This changes the last modified date on the file and thereby stops the autosave popup.

touch *.jpg
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.