Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows native text-to-speech program to read web pages and pdf files.
Whenever the reader encounters a special character (or a blank space of some sort), it says "ASCII". Is there a way to make the reader skip such characters or not say "ASCII" at all?

share|improve this question
    
Native text-to-speech program? Is it Narrator? –  Bob Apr 14 '12 at 7:25
    
It's the predecessor of Narrator. In Windows Vista and Windows 7, Narrator has been updated to use SAPI 5.3 and the Microsoft Anna voice for English. wiki –  Forethinker Apr 14 '12 at 7:31
    
A predecessor of Narrator? SAPI refers to the voice engine. The program called Microsoft Narrator has been included with Windows since 2000, with various versions. Windows 7's version uses SAPI 5.3, but the program is still called Narrator. Microsoft Office, for example, also uses SAPI in its built in text-to-speech functions. My question to you is, what is the name of the program you are using for text-to-speech? SAPI appears to store some settings in HKLM\Software\Microsoft\Speech and HKCU\Software\Microsoft\Speech. –  Bob Apr 14 '12 at 7:41
    
Oh I see. My misunderstanding. I am using Adobe Acrobat Reader for pdf's and Announcify Chrome Extension for webpages. I have glanced over the registry, but I am not quiet sure where this feature (or bug) can be modified. –  Forethinker Apr 14 '12 at 7:56
    
Could you provide an example file or sentence of some sort? Testing Adobe Reader X's Read Out Loud using Microsoft Anna on Windows 7 on a document with random alt code characters (Testing testing 123 ˜⾅󘥧 㤾񍐐× Testing) just reads "testing testing one hundred twenty three tilde <pause> testing"... in other words, it skips the unpronounceable characters. Check Edit > Preferences > Reading, which voice is selected? Also check the voice selected (and voices available) in Change text to speech settings, available from Start Menu search. –  Bob Apr 14 '12 at 8:09

1 Answer 1

up vote 0 down vote accepted

You have not provided a sample PDF document, so I could not test that.


Testing your provided page with Chome's Announcify plugin:

It doesn't say ASCII (not ay ess see eye eye nor ass-kee) for me. On some spaces, it does say dot and n b s p <pause>. Looking at the source code for the page, it is evident that Announcify is not converting HTML elements before sending them to the speech engine. The dot is the full stop (period). &nbsp; is an HTML element, non-breaking space, which should have been converted to a space before reading. That's a bug in Announcify which should be reported to its developers. Special characters could be encoded similarly; an ampersand would be &amp;. The ; becomes a pause, as a semicolon is supposed to be read in English.

Microsoft's text to speech engine is designed for literary text. More technical texts, especially in programming where punctuation should be read out, could cause problems. For example, the speech engine pauses when reading the colon (:) and comma (,), and completely ignores quotes, as should happen if it were reading an English literary passage. There's not much you can do about that.

share|improve this answer
    
For me, I found that the previously described issue occurs when I have double space. It may have to do with the Unicode setting on my OS. I am currently learning javascript to remove double space into single space, but thank you for describing the inherent nature of the problem. –  Forethinker Apr 26 '12 at 7:09
    
It's not a double space, more a special space. The thing is, after each &nbsp; is a normal space, so it looks like a double space. In that particular document, you can just strip out the &nbsp;s... but for a more compatible solution, replacing with normal spaces should work. –  Bob Apr 26 '12 at 7:20
    
The real problem here is Announcify is throwing the HTML source at the text-to-speech engine, rather than the rendered HTML as its supposed to. –  Bob Apr 26 '12 at 7:59
    
I looked through userscript.org to see if nbsp can be removed. None of the scripts worked, do you happen to know the solution? –  Forethinker Apr 28 '12 at 0:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.