Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I went to Bundles -> Edit Bundles and then picked PHP then Settings and this I unchecked Enable this for Indentation Rules, and now I cannot re-enable it because it's greyed out and I cannot even click it. How can I re-enable it?

share|improve this question

1 Answer 1

I'm assuming this is for TextMate 2 since this problem doesn't exist in TextMate 1 AFAIK.

Located inside the folder ~/Library/Application Support/Avian/Bundles/PHP.tmbundle are all the 'deltas' for your bundles. A 'delta' file is a record of the changes you have made to the 'standard' bundles. TextMate records the changes rather than applying them directly to the bundle to allow the bundle to be updated without erasing your changes (among other reasons).

Find the file for the command or setting you want to reenable. Either open the file and change the key 'isDisabled' to false if you want to keep other changes you have made, or simply delete the file if you want to revert to the default.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.