Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At work we have both a guest wifi and wired lan.

When Im plugged in to the lan and have the wifi turned off, I get a local dns server which resolves internal servers correctly.

But if I have my wifi enabled and both cabled and wireless networks are enabled, the dns server from the wifi is being used.

My wired NIC has a lower metric, so Id think the DNS server from that NIC should be chosen, but this seems not to be the case.

How can i tell windows to use our local DNS when connected to the LAN even if wireless connection is enabled and connected to guest network?

This is on windows 7.

thanks in advance

share|improve this question
    
Just the DNS? Here on both windows system XP and 7 , having an active Wireless (internet) connection overrides the wired and many times faster Lan connection for all the internet access stuff. I just disable the wireless with devcon. (or the other or both as desired) Mabey what your talking about is the way it all clings in the caches? Then there are programs that also have thier own ways of doing dns caching too. Do you have specific programs that are important to the question? –  Psycogeek Apr 14 '12 at 18:58
    
To clarify, is this your situation: Machine gets DNS servers by DHCP on two connections (possibly at different times). Both connections are operational, and you want to control which connection's DNS server settings are used. (Also, is this Windows 7?) –  David Schwartz Apr 14 '12 at 20:14
    
Yes, this is on Windows 7 (updated question). Both DNS servers are given by DHCP, both connections are operational. I could turn off Wifi and be happy, but Im not happy when I have to do work the computer could do for me ;-) I want it to use the DNS server of the NIC that has lowest metric, i suppose. –  Brimstedt Apr 15 '12 at 19:39
    
Oh, and ive tried clearing the dns cache, both OS and software. –  Brimstedt Apr 15 '12 at 19:40
add comment

2 Answers

up vote 1 down vote accepted

You can change the order in the advanced network settings, as seen in screenshot

Windows advanced network settings

share|improve this answer
add comment

There is a similar topic on this subject. Key bit of info is the last post basically saying all the obvious things don't work and suggesting a Microsoft workaround.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.