Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Following this, I'm trying to stream video over the network.

The settings are:

me@kaffeesatz:~$ vlc screen:// --screen-left=67 --screen-top=53 --screen-width=800 --screen-height=600 --screen-fps=60 --sout '#transcode{vcodec=theovb=800,scale=1,width=800,height=600,acodec=none}:http{mux=ogg,dst=localhost:8181/graph}'

But when I try to open the the.ip.address:8181/graph from vlc on another computer, I get the error message:

Your input can't be opened:
VLC is unable to open the MRL 'http://the.ip.address:8181/graph'. Check the log for details.

What am I doing wrong here?

In the meantime, I verified that I can open the stream on the machine I'm streaming from. Opening the stream from another computer however still doesn't work.

Here's the log output:

main debug: processing request item http://192.168.178.23:8181/graph.ogg node Playlist skip 0
main debug: resyncing on http://192.168.178.23:8181/graph.ogg
main debug: http://192.168.178.23:8181/graph.ogg is at 1
main debug: starting new item
main debug: creating new input thread
main debug: Creating an input for 'http://192.168.178.23:8181/graph.ogg'
main debug: thread (input) created at priority 1 (../.././src/input/input.c:220)
qt4 debug: IM: Setting an input
main debug: thread started
main debug: using timeshift granularity of 50 MiB
main debug: using timeshift path 'C:\Users\lowerkey\AppData\Local\Temp'
main debug: `http://192.168.178.23:8181/graph.ogg' gives access `http' demux `' path `192.168.178.23:8181/graph.ogg'
main debug: creating demux: access='http' demux='' path='192.168.178.23:8181/graph.ogg'
main debug: looking for access_demux module: 0 candidates
main debug: no access_demux module matched "http"
main debug: TIMER module_need() : 5.667 ms - Total 5.667 ms / 1 intvls (Avg 5.667 ms)
main debug: creating access 'http' path='192.168.178.23:8181/graph.ogg'
main debug: looking for access module: 2 candidates
access_http debug: http: server='192.168.178.23' port=8181 file='/graph.ogg'
main debug: net: connecting to 192.168.178.23 port 8181
main warning: connection timed out
access_http error: cannot connect to 192.168.178.23:8181
main debug: net: connecting to 192.168.178.23 port 8181
main warning: connection timed out
access_mms error: cannot connect to 192.168.178.23:8181
main debug: no access module matching "http" could be loaded
main debug: TIMER module_need() : 10181.896 ms - Total 10181.896 ms / 1 intvls (Avg 10181.896 ms)
main debug: waitpipe: object killed
main error: open of `http://192.168.178.23:8181/graph.ogg' failed: (null)
main debug: thread ended
main debug: dead input
main debug: thread times: real 0m10.257812s, kernel 0m0.000000s, user 0m0.000000s
main debug: changing item without a request (current 1/2)
main debug: nothing to play
qt4 debug: IM: Deleting the input
main debug: TIMER input launching for 'http://192.168.178.23:8181/graph.ogg' : 10360.760 ms - Total 10360.760 ms / 1 intvls (Avg 10360.760 ms)
share|improve this question
1  
Did you check the log for details, as the error message suggests? – Indrek Apr 14 '12 at 19:03
    
I tried to, but the log is nowhere to be found, even when I enter a log file path. – lowerkey Apr 14 '12 at 19:21
    
Update: Found the logs, posted them in the question. – lowerkey Apr 14 '12 at 19:35
up vote 4 down vote accepted

When setting up VLC on the server, don't specify localhost for the destination, just the port number:
vlc screen:// --screen-left=67 --screen-top=53 --screen-width=800 --screen-height=600 --screen-fps=60 --sout '#transcode{vcodec=theovb=800,scale=1,width=800,height=600,acodec=none}:http{mux=ogg,dst=:8181/graph}'

share|improve this answer
    
Have many thanks! I never would have guessed! – lowerkey Apr 14 '12 at 20:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .