Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is obscure.

When connected with RDP to another system that has HP Update installed on it, either directly running the HP Update or having the notification pop up to ask if you want to run HP Update causes the local system to try to print something to peculiarly-chosen-local-printer.

Case 1: Desktop Win 7 Ult system RDP connected to HP Laptop Win 7 Ult system. When HP Update runs on the laptop a dialog for XPS Writer Save As... appears on Desktop system.

Even if you put in a name, nothing gets generated and the dialog repeats. And repeats. Until you (a) close the RDP connection and (b) clean out the queued entries.

If the HP Update pops up the request to run the update and you are not at the desk when this happens, there can be dozens of queued requests for this bogus printing.

NOTE: the XPS Writer is not selected as a default printer on either system.

Case 2: (Different) HP Laptop Win 7 Ult system RDP connected to XP Pro "brand X" desktop system but with HP printer drivers installed.

If the request to run HP Update notification pops on the XP system, dozens of attempts to print, in this case to a Versa Check Printer driver, are queued.

Dismissing the HP request, closing RDP, and cleaning out the queue are required to stop this.

NOTE: the Versa Check Writer is not selected as a default printer on either system.

THE QUESTION: What the heck is going on here? Some kind of scripting or COM activity that is misdirected?

share|improve this question
    
You might update (or request it be updated) the HP update program on that particular PC, they have new versions released over the years, always fixing bugs. –  Moab Apr 15 '12 at 0:04
    
Thanks but HP Update was updated already. geekosaur below had the right idea. I found two ways to stop this behavior (which clearly is an HP bug). Delete the XPS Writer or don't forward printers in RDP. –  lcbrevard Apr 15 '12 at 15:51

1 Answer 1

up vote 1 down vote accepted

RDP forwards printer shares by default; it sounds like HP Update is apparently mis-seeing those printer shares as file shares and doing a file test that gets turned onto a print job. (I'm aware of a similar bug in a different package.) A workaround would be to disable forwarding printer shares to the remote.

share|improve this answer
    
That is a very good point. I tried several times to let the XPS Writer print but there was nothing there. That HP Update is probing file systems (or ports) makes sense. I just tried to verify this but I had deleted the XPS Writer that was being triggered and the problem is gone no matter how I connect. I'm going to try the other system that was triggering the Versa Check printer. Maybe it's the forwarded "port" for these odd printers. –  lcbrevard Apr 15 '12 at 15:40
    
I ran some experiments. After I put back the XPS Writer, HP Update triggers the bogus print if printing is forwarded in RDP but does not otherwise. To see if it was PORT forwarding, I left off printer forwarding but turned on port forwarding (found with the More... button). That did NOT trigger the bogus printing. So... I have two workarounds at this point but this is clearly a bug in the HP Update software. –  lcbrevard Apr 15 '12 at 15:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.