Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Precision T5400 with a Broadcom 1Gb onboard NIC. For some strange reason, when I access machines on our local network, the best I can get is around 125KB/s download speed. My laptop that has a 10/100Mb NIC onboard usually gets around 300KB/s or better from the same network resource. Both machines are plugged into the same 1Gb switch which connects to our local network wall jack at 100Mb half duplex. There is also a printer plugged into the same switch at 100Mb full.

The resource I'm using for the test is a 30MB zip file copied from a jetty webserver that is running as part of a cruisecontrol installation. The cruisecontrol installation is running WindowsXP with full real-time antivirus and Altiris patch management and inventory running. That stuff on its own is eating some of the download speed. I've seen the laptop reach into the multiple MB/s download speed before, but the desktop never seems to get past 125KB/s to 130KB/s.

In WindowsXP, before I upgraded the driver in the desktop, it was that slow. In Fedora, it is still slow even though it appears to be using the same driver version as the upgraded Windows driver. The upgraded Windows driver is faster, but still not nearly as fast as the laptop.

What gives? Any insight to improve the situation would be appreciated.

Could it be that the BroadCom board just isn't that good, or the driver in linux is just not as good as the Windows one?

share|improve this question
    
125KB/s equates to exactly 1 mbps throughput... Is there any roadblock in your network (a switch, hub) that is only 1 mbps? –  Breakthrough Sep 14 '09 at 21:26
    
No roadblock. The laptop passes through the same set of network hardware and gets more than double that speed. –  Jay R. Sep 14 '09 at 21:54
    
This issue appears to be what Jeff was talking about for the stackoverflow network problems. The switch we are using is cheap and only autonegs so the closest we can get with it is to force all of the hardware to turn off autoneg. –  Jay R. Feb 25 '10 at 0:40

2 Answers 2

Try setting the network speed manually to 1 gbps full duplex if you are currently using auto-negotiation.

share|improve this answer
    
I tried that. It made no difference. I also tried setting it to 100Mb full. Still nothing. –  Jay R. Sep 14 '09 at 21:35
    
Do you have any packet loss when pinging ether the laptop or other machines on the network? Have you tried hooking the T5400 directly to the wall? Both machines are getting really bad speeds even for a 100mbit network so it seems the problem is in the infrastructure. –  Console Sep 14 '09 at 21:53
    
I don't see any packet loss, as far as reported by netstat and others. I'll add more about the resource in the question. –  Jay R. Sep 14 '09 at 22:00
    
I didn't set the speed correctly before. 100Mb full does make some difference. 100MB half makes even more difference. –  Jay R. Feb 25 '10 at 0:36

I removed the 8 port Linksys SD2008 switch from between my machine and the wall. Now I can see better than 6MB/sec from the same server.

I set the NIC speed to 100, duplex to half, and turned off autoneg. Now I'm seeing better speed but not as good as the wall speed.

For linux this is what I typed:

sudo ethtool -s autoneg off speed 100 duplex half
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.