Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using additional monitor with my laptop for a few weeks (extended setup), and today it started entering a power saving mode with no apparent reason. Laptop's monitor keeps working fine, laptop works fine too (i.e. it's only the external monitor that's in ps mode). When I replug external monitor it's fine again for about 2-3 minutes, then it enters power saving mode again.

The only thing I did I can possibly relate to this problem is I updated NVidia graphics card drivers yesterday. They were badly outdated before.

Specs:

  • Laptop: Samsung R510
  • External monitor (the one screwing up): LG Flatron E2351
  • Graphics card: NVidia GeForce 9200M GS
  • OS: Windows 7
  • Power settings: high performance & never enter power saving mode :)
share|improve this question

1 Answer 1

up vote 2 down vote accepted

I administer nearly 500 machines in my job and from experience, this problem usually arises from issues with the monitor more than the graphics card or drivers and I've nearly always had to replace the monitor to get the machine up again. Is there another computer you can test it on to see if it still enters sleep mode just to narrow it down?

share|improve this answer
    
I had a chance to test it on another machine just now, and so far it seems to be working fine. –  Sejanus Apr 17 '12 at 6:09
    
Ok good, that means your monitor is probably working fine. I suspect the drivers are at fault, did you get them through Microsoft or NVidia? –  hardlywired Apr 17 '12 at 11:41
    
at first I had GeForce drivers downloaded from Samsung (or maybe somwehere else but explicitly stated "for Samsung R510" anyway). A day before the problem started I updated these drivers from NVidia website since they were outdated badly and some games refused to run with this explicit reason. Is it possible that official NVidia drivers are not meant for the, I dont know, laptop version of gpu? But I updated them using NVidia's auto-detect-your-gpu software maybe this can be part of the problem as well? And yes I ran monitor for 8+ hours on another pc, all was fine. –  Sejanus Apr 18 '12 at 8:17
1  
Sorry, I have been away for a few days. I would try rolling back the drivers you installed and updating from the laptop vendor site and not NVidia or not even updating them altogether. Often newer doesn't necessarily mean better in the world of drivers. –  hardlywired Apr 23 '12 at 2:43
    
Yep I reinstalled old official samsung drivers and everything seems to be fine now. I'll wait a few more days before closing the question. In any case thank you for your help! –  Sejanus Apr 23 '12 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.