Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a newly installed Office 2010 installation on a Windows XP machine, but whenever I try using some of its features, like equations in Word, I get this message:

The function you are attempting to run contains macros or content that requires macro language support. When this software was installed, you (or your administrator) chose not to install support for macros or controls.

I have tried reinstallig, and opening the control panel to add Visual Basic to Office's characteristics. Of course when installing, I didn't disable macros at all (to my knowledge)

I've tried almost all solutions listed on forums found by searching the problem on Google...

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I came across your question when trying to solve this myself, because I messed in the registry some time ago and I remember that I had disabled VBA a while ago without know that this would disable equations.

This approach worked for me:

  1. Make sure that the Visual Basic for Applications feature of Office is installed.

  2. Make sure that there is no VbaOff entry in the registry under the Office key.

However, if the problem lies deeper (more likely for you), you need to:

  1. Completely remove Office.

  2. Remove the Office keys from the registry which were left behind (seach for Office keys).

  3. Do a full non-customized installation of Office, or at least make sure that VBA is installed along...

share|improve this answer
    
I'll try as soon as I can, thanks! –  Chevi Apr 19 '12 at 7:17

You can follow the steps given below:

  1. Close all the office applications.
  2. Click on Start -> Control Panel -> Programs-> Programs and Features.
  3. Click on Microsoft Office 2010 and click on change.
  4. Click on continue for Add/remove features.
  5. Expand Office Shared Features.
  6. Click on the little arrow attached to Visual Basic for Application and select Run from my Computer-> continue.
  7. Click close once the configuration window and try to open word documents.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.