Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've found similarly titled questions, but none that directly address my issue. I'm running Google App Engine server on my Macbook, and it was configured to use port 8080 on localhost. And so anytime I wanted to run my site, I'd just go to localhost:8080/saveuser and everything worked fine.

Now, I want to access this same site on my iPhone. I can't just do localhost on my iPhone, so I set up Web Sharing on my mac, and it's set up to I can access this from my iPhone, but it only displays a directory of my files, and doesn't actually run the Python script. The only way my Python scripts actually run is if I do localhost:8080 on my computer.

What can I do about this?

share|improve this question
Have you tried If so, did you setup your python server to bind to or or something like that? – Apr 15 '12 at 16:27
Ya tried that, that doesn't work on neither my computer or iPhone. When I access, it says this on the bottom: Apache/2.2.21 (Unix) DAV/2 PHP/5.3.8 with Suhosin-Patch Server at Port 80 – maq Apr 15 '12 at 16:29
Not sure what port 80 Google App Engine server is configured on port 8080. If I try to change the configuration to port 80, I get a configuration error – maq Apr 15 '12 at 16:30
I know what port 80 means..I just don't know what it means for my problem. My Google App Engine server is configured to port 8080, and if on the bottom it says port 80, that could be the reason it's not working. I just don't know what to make of it – maq Apr 15 '12 at 16:37

You must log in to answer this question.

Browse other questions tagged .