Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to unarchive a file to the /Developer folder.

Install Qt for iOS SDK

The Qt for iOS SDK has been configured to be installed in the default Xcode installation location /Developer. It is not possible to install the SDK into another location without first rebuilding it, as the install location is contained within the qmake executable, and that is built as part of Qt.

To install the Qt for iOS SDK, open ‘Terminal’ and type the following from the command­‐line:

tar –xf qt­‐everywhere-­ios­‐4.8.0­‐xxx.tar.gz –C /Developer

(where xxx is an identifier which can be used to determine the build of the iOS SDK eg. arm7-­‐nossl) This will install the Qt for iOS SDK into the following path:


When I perform the operation I get the information:

Lions-Mac:Documents User$ tar -xf qt-everywhere-ios-4.8.0-arm7-nossl.tar.gz -C /Developer 
tar: could not chdir to '/Developer'

Any idea what is wrong?

share|improve this question
tar -C /Developer -xvvvf qt-everywhere-ios-4.8.0-arm7-nossl.tar — does that add any details? Can you open the file by double-clicking it? – slhck Apr 15 '12 at 21:21
yes I can open it by double-clicking. But I need to do it according text in EDIT – user123_456 Apr 15 '12 at 21:26
Have you considered that the file is broken due to e.g. aborted download, or transmission errors? – Daniel Beck Apr 15 '12 at 21:29
One command says .tar, the other .tar.gz. Are you actually using the correct file name? – Daniel Beck Apr 15 '12 at 21:30
I think the file is correct because I can double click it and unarchive it, but I want to do it as they said in the text above. I have tried '.tar' and '.tar.gz' and the same thing is happening – user123_456 Apr 15 '12 at 21:32
up vote 0 down vote accepted

If tar is missing permissions to write there, use the same command, but prefixed with sudo.

sudo tar -xf qt-everywhere-ios-4.8.0-arm7-nossl.tar.gz -C /Developer

This will perform the command with root permissions.

share|improve this answer

It's a gzipped tar file (see the .gz extension), so you need to add z.

tar -xzf qt-everywhere-ios-4.8.0-arm7-nossl.tar.gz -C /Developer
share|improve this answer
I have tried it and the same thing is happening – user123_456 Apr 15 '12 at 21:24
I have put more details in the EDIT if that even helps – user123_456 Apr 15 '12 at 21:27
@denonth Where did you get that information from, though? Can you add a link or so? – slhck Apr 15 '12 at 21:40
Here is the link: – user123_456 Apr 15 '12 at 21:41
See the updated question – your answer might be obsolete now. – slhck Apr 16 '12 at 11:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.