Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Word 2007 document in which the Figure numbers and List of Figures are listed exactly as I want. I generate a pdf (Adobe Reader X, Version 10.1.2) from Word 2007 document using the save as option. The List of Figures in the pdf document comes out exactly as present in the Word document, however, when I click on a Figure number in the List of Figures, I see a different number on the actual Figure than present in List of Figures.

For example, I have this Figure number on List of Figures:

enter image description here

But the corresponding Figure on Page 61 shows following Figure number:

enter image description here

Figure number is becoming 4-21 from 4-7 because the total number of Figures from Chapters 1 till this Figure are 20. However, I want break in number of Figures between each Chapter i.e. Figures for Chapter 4 should start from 4-1, so the number 4-21 is actually 4-7 in that case.

How can I correct this? Thanks.

share|improve this question
    
Do the numbers change when you Print Preview the document in Word? –  iglvzx Apr 17 '12 at 22:56
    
Numbers change when I save the Word document as pdf from the save as option in Word 2007. On saving as pdf, the numbers under the Figures change both in the original Word file as well as the pdf file. However, the numbers in List of Figures do not change. –  Pupil Apr 17 '12 at 23:02
    
I know that. I am asking you if they change when you print or print preview. If they do not change, you could use a virtual printer (i.e. Print to PDF) as workaround. –  iglvzx Apr 17 '12 at 23:04
1  
Yes the numbers change during print preview. I have tried converting the word file to pdf through online services, but even the file through their conversion also contains changed numbers. Another anomaly is that the numbers for Chapter 7 do not change. But, wherever Chapter 7 ends, the next Chapter with Figures have changed numbers and their numbering starts with number which is next after Figure number where Chapter 7 ends. –  Pupil Apr 17 '12 at 23:10
1  
OK, so Word may not really know about your chapter numbers - it's just numbering the figures as a single list of figures. Unless you're captioning with a format that includes the chapter number, this seems like expected behavior. I think that the numbering issue you're seeing is because (at least in 2003, details on 2007 seem skimpier) you often had to select the table of contents/figures/index and hit F9 to force a refresh. This may also be relevant: cybertext.wordpress.com/2008/04/27/… –  fencepost Apr 18 '12 at 4:24

1 Answer 1

up vote 1 down vote accepted
+50

Ok, here's a nice meaty sample document (https://docs.google.com/open?id=0B4qT-cHb903mS3k3bjZoTV95Slk) that I should be able to leave out there just about forever. It's large because it includes CC pictures as sample figures. I'm also including the notes section of it that should have enough information to recreate what I did or at least get you close to solving your issue - the document just provides a "live" example so you can look at field codes, etc. but the important values are documented here.

Chapter titles are formatted as Heading 1, and chapter numbering is done by having the cursor within the first chapter name, going to the Home tab, selecting the multi-level list button/dropdown and selecting a numbering format.

To keep Word from making the Table of Contents into Chapter 1, click into the Contents heading, select the multi-level list button, and change the formatting there to None. I did this after I had already right-clicked on the Notes chapter heading and told it to restart numbering at 1. This was a bit squirrely, as it initially had the chapter numbering in the figures off by one. Inserting a Next Page Section Break (Page Layout tab, Page Setup section, Breaks dropdown) after the Table of Contents then redoing the chapter numbering (e.g. resetting start at 1, etc.) seemed to take care of this after I changed the Heading 1 Style to have a page break before it, which caused the chapter numbering to reset to default including the Table of Contents.

Pictures were simply copied and pasted, then the text wrapping was set to Square to make them float, then they were dragged around a bit. They’re not anchored to spots in the text though they probably should be.

Picture Captions were added by right-clicking the picture and selecting Insert Caption; the caption numbering was set to Automatic and told to include chapter numbers (which is where setting chapter numbering comes in up above).

A bunch of this is actually controlled by Fields, press Alt-F9 to see the field codes. It’s likely worth noting that the field codes for my captions are “Figure {STYLEREF 1 \s}-{SEQ Figure * ARABIC \s 1}", the \s doesn’t appear to be well documented, at least not within the STYLEREF info. Additional information here: http://wordfaqs.mvps.org/styleref.htm

UPDATE: It looks like this MSDN page may be the best reference relevant to this: http://msdn.microsoft.com/en-us/library/aa163918%28v=office.10%29.aspx In particular, the "\s 1" tells the field code to restart the figure numbering at the most recent heading of the specified level (here, level 1).

share|improve this answer
    
fencepost: Chapter number associated with Figures doesn't increases. It's set at 1 and shows that everywhere. –  Pupil Apr 21 '12 at 6:32
    
Right, but because you put the chapter number in the caption manually instead of using the chapter field code, it's treating the figure number as being for the entire document. If you hit Alt-F9 what does your field code for the figure number in the caption look like? –  fencepost Apr 21 '12 at 23:14
    
Hi fencepost: It looks like this - { SEQ Figure\* ARABIC }. –  Pupil Apr 21 '12 at 23:55
    
fencepost: I pressed Alt-F9 and even the documents which were not opened are changed now and showing code all over the documents wherever Figure is placed. How to revert them back to normal view without field codes? –  Pupil Apr 22 '12 at 0:04
1  
Sorry, was away but it should be Alt-F9 again - it's a toggle between the two values. I think Ctrl-Shift-F9 converts field codes back to fixed text so they'll never update again; I hope that's not the case for what you did here. also, try adding the "\s" shown in my example to your field code - that may take it over to basing on the current chapter. –  fencepost Apr 22 '12 at 2:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.