Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For the past couple of weeks, my laptop has had a strange problem where it looks like Ctrl+Z is pressed, so I usually lose bits of text I've just typed. If I redo by pressing Ctrl+Shift+Z, the text comes back, proving it's really as if Ctrl+Z was pressed.

It's difficult to see a pattern; I can be undo-free for hours, then get a few within minutes, sometimes 2-3 undoes at a time. Very frustrating!

I'm running Windows XP SP3 on a Dell Latitude D820 laptop, Clamwin antivirus.

I've tried another keyboard, no difference.

Any clue on what this could be, or how I could trace the problem?

Update: I've tried a few things that were listed or linked to on this page but nothing helped. It does seem though to point to a Dell laptop issue. I've upgraded the BIOS and other drivers, but still have the problem.

share|improve this question
    
My Dell laptop (Studio 17) also has a problem with random erratic keyboard signals being sent to the system. Correct me if I'm wrong but the latitude is the business laptop? Maybe a BIOS issue. –  Macha Sep 14 '09 at 23:06
    
Yes Latitude is a business laptop. I don't remember touching the BIOS for a very long time... I'll see if there's a update available. –  squelart Sep 14 '09 at 23:55
add comment

5 Answers

up vote 1 down vote accepted

By trying another keyboard this doesn't mean that the laptop keyboard wont be active, to do so, go the control panel >> system >> device manager, look for "Standard 101/102 keyboard"(or something like that) right-click and select "Disable". (this make your laptop keyboard disabled)

Now, try with your external keyboard, if this problem don't shows up again, this is for sure a broken laptop keyboard, you need a replacement.

share|improve this answer
    
Good point. However, there's no "disable" option in the device manager, only "update driver" and "uninstall", but this seems a bit drastic and dangerous... Suggestion? –  squelart Sep 21 '09 at 1:05
    
It must be a hardware issue: When I press on the front left part of the laptop, it starts sending Ctrl-Z like crazy! Will try to get it fixed... –  squelart Sep 30 '09 at 1:37
    
I see you have already asked about disabling a laptop keyboard :-) superuser.com/questions/44572 –  squelart Sep 30 '09 at 1:45
    
i already asked about How to disable a keyboard ,foy you :), here : superuser.com/questions/44572/how-to-disable-a-keyboard, but still not getting a valid anwser –  Revolter Oct 1 '09 at 11:31
add comment

Make sure there isn't any device plugged into your system (say, by USB) that may be causing spurious keyboard events. The most obvious is a USB keyboard that maybe is under a stack of papers or stashed behind your desk, etc. But it may be something completely NON-obvious, as there are some non-keyboard USB devices that actually function by emulating a keyboard. A friend of mine was having the darndest time trying to figure out why his computer would randomly type out gibberish; turns out that it was the fault of his USB arcade joystick, which he had stashed on the floor. It works by emulating keypresses, and every time he hit it with his foot, the chair leg, etc., it would register a keypress. We had a good laugh over this one when he finally figured it out.

share|improve this answer
    
Thanks for the tip, but in my case I had the problem even when absolutely nothing was plugged to the laptop. –  squelart Sep 15 '09 at 7:40
add comment

Here's what almost worked:

  1. Power off.
  2. Remove the main battery.
  3. Press the power button a few times, sometimes holding it for a dozen seconds.
  4. Keep doing that all weekend!
  5. Re-assemble everything, problem gone.

This is based on comments found in http://www.selfishman.net/2008/06/24/problem-with-dell-inspiron-1501-keypress-every-second/. Step 4 is what made it work for me.

2009-09-29: Arrgh, after a couple of days without problems, it started again! :-( Still looking for a fix then...

share|improve this answer
add comment

Wow. Dell Latitude D820...I thought to myself "none of those causes make any sense". Then I tried holding my hand over the built-in keyboard and rubbing my foot on the carpet. ctrl-z,ctrl-z,ctrl-z to the point where half of the doc I was working on disappeared. No real problem. I never experiment without saving, and rapid-fire ctrl-y brought it all back. Then I tried drumming my fingers on the front left corner of the case...same issue. Most of the time, I'm not even touching the laptop itself, however. Makes me wonder if the others who have this issue always have their laptop on a docking station. Could it have to do with movement of the docking station connection?

share|improve this answer
    
Okay. Then each time I flick the "Wireless" switch on the side, I get a single ctrl-z. –  Yves Nov 24 '09 at 22:46
add comment

Honestly, the answer might be really simple. I've had problems like this before. It turned out there were crumbs/ dirt under the key (in your case probably the 'z' key). If you remove the key and things under it, your problem might be solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.