Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just started a new session on my windows7 laptop to find everythings missing.

My desktop is "empty" and everything in the windows menu seems to be missing. I can reach the apps (like google chrome for example) by searching them on the windows menu search box. When I right click on them and chose properties, I get the path:

C:\Users\My Home\foo\bar

The "My Home" folder is unreachable otherwise and clicking on "open file location" always opens an empty folder. Seems like it's gone, but still I can reach the apps by searching on the windows menu like I said before.

This is kinda weird, I'm pretty sure I dind't delete anything.

Also when checking via the command line, dir doesn't show a thing but pressing TAB autocompletes the files that should be there.

I'm puzzled :S. Thanks for the info.

share|improve this question

3 Answers 3

I have seen this with some sort of malware. The malware changes the file attribute to Hidden and makes other changes. Check to see if your files have been changed to Hidden.

Discussion here suggests a fix but it has never fully worked for me. McAfee has a suggestion here but I have never used this tool. Symantec Endpoint recovery disk was able to remove once but every other time was a reimage as that was faster.

share|improve this answer

I sometimes see this after an update, including this last patch Tuesday's updates. Rebooting has always fixed it.

Only seems to happen on the machine with System Mechanic Professional so it's possibly some interaction between booting right after a patch and some function of SM like registry cleanup.

share|improve this answer

If you create desktop shortcuts to removable storage places such as NAS the icons will disappear from time to time because Windows 7 has a built in task schedule to clean up broken and unused links.

To prevent the task from running you need to disable the task in the task scheduler:

Start---programs----accessories----system tools----task scheduler

Expand the tree in the left hand pane until you get to Task Scheduler Library-Microsoft-Windows-Diagnosis. In the right hand pane, right click the task named Scheduled and click Disable

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.