Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hello everyone I have a SD memory card which is of local manufacturer it allows to read & copy from it but not write as it is now write-protected so i want to format that card but could not. To format this card I have tried

1) DD command

2) mkfs -f vfat command

3) creating registry entry under storage device policy in window with write value 0

4) disk part command in window to clear attributes in which it show all attributes are clear ie no write protection

5) I format card in windows through control panel -> administrative tools-> computer management -> disk management, then it show as formatted but when I tried to create new partition it give CYCLIC REDUNDANCY CHECK error

6) I downloaded a format utility from transcend site and formatted first it shows write protected again doing format it formats and tells to remove and reinsert after reinsertion it shows the previous data as it is

share|improve this question

migrated from stackoverflow.com Apr 16 '12 at 1:54

This question came from our site for professional and enthusiast programmers.

2  
This may be a silly question, but you didn't accidentally slide the write-protect switch to "Lock", did you? cs.uga.edu/~maria/classes/4900-Spring-2011/figs/… –  Dr Kitty Apr 16 '12 at 2:06

2 Answers 2

You might have a defective card reader. Try another one.

If that doesn't work, the card may very well be bad and the data on it unrecoverable. Restore your data from backup on a new card.

share|improve this answer

try booting into a partition editor (partition magic for example) make a new partition layout and format from there. It has worked for me before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.