Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In order to connect to my Android Galaxy 10.1 tab, I'm trying to use WiFi Explorer, which sets up the tablet as being a file server on the WiFi LAN, accessable by local IP address.

The app says that I can connect to my tablet from my Ubuntu desktop computer by going to 192.168.0.21:8000. But whenever I try that address in my browser, it says "Unable to connect".

I think this is because of the way my WiFi network is set up. I have an Aterm router which does not have a WiFi option on it. Connected to that is a Logitec wireless router.

So the connection I am trying to make is:

Ubuntu Desktop -> Aterm Router -> Logitec Wireless router -> tablet device

I think what's happening is that the Logitec is assigning the IP address to the tablet, so the Aterm router doesn't know about it, and the Desktop can't find it.

How do I go from my Desktop, though my routers, to talk to the tablet at it's assigned IP address (it's using static IP, by the way)?

share|improve this question
add comment

1 Answer

Probably the easiest way is to connect the desktop to the wireless router if it has LAN ports. Otherwise you need to use Port Forwarding or NAT.

Also -- what is the reason for having 2 routers?

Edit: based on OP's comments, it appears that the second router is not set as a router, but access point. What I am suggesting is:

                              192.168.0.1 (to Atern Router)
                              192.168.1.1 (interface to  tablet and desktop)
                                  *
 internet -> Aterm Router -> Logitec Wireless router -> tablet device   (192.168.1.x)
                                  |
                                  | --------------- > Ubuntu Desktop  (192.168.1.y)

That however didn't solve the issue, it seems that something else is blocking the connection

share|improve this answer
    
Router A is also the optical cable modem. It's required by my ISP in order to connect. It has a WiFi option, but to enable it, I have to pay a ridiculous monthly service fee. So I just got a second router with WiFi for a few bucks. –  Dave M G Apr 16 '12 at 8:21
    
Ok, I see. But then you can just connect the desktop to the second router (I assume it has LAN ports), this way the desktop and the tablet would be on the same local network and should "see" each other. –  lupincho Apr 16 '12 at 8:27
    
@Dave M G - Are you able to ping the IP address of the tablet? Am guessing you are on the same subnet as well. –  PeanutsMonkey Apr 16 '12 at 8:32
    
@lupincho: The problem with that solution, unless I'm mistaken, is that then I'd have to find a way for devices connecting by WiFi to connect out to the internet by going through the computer and finding the router. So it's kind of the same problem, just going a different direction. –  Dave M G Apr 16 '12 at 8:33
    
@DaveMG: It shouldn't be a problem if the second router gets IP address from the first and devices connected by WiFi or LAN to the second modem get their IP addresses from the second. Usually when everything is set to get IP addresses automatically via DHCP the routers handle this and it should be transparent to the user and devices. Try to connect the desktop to the second router (you said that something has an fixed IP, if it is the desktop, either set it to automatic IP or choose fixed IP in the range served by the second router). If that connects to internet, most WiFi devices would work. –  lupincho Apr 16 '12 at 8:36
show 17 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.