Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As in the title, that shortcut doesn't work, and I can open a new tab only with pushing the scroll. Since the CTRL key works perfectly in the other environments, what's wrong with Chrome?

I'm using the latest Chrome on Windows 7 Home Premium on a Samsung NP305V5A-S03IT.

Update: I changed laptop two months ago, and it's not working since then. In the previous one it was working, so I know that it should work.

I could also try to reinstall, but since it's annoying I would like to try simpler solutions first.

share|improve this question
Since when does it fail to do that? Have you installed anything? – slhck Apr 16 '12 at 12:50
Does not work on any site or just on certain sites? Find that some sites are coded weirdly and Ctrl+Click and/or Middle-Click do not work. Right-Click->Open New always does though (at least on real links; you cannot open JavaScript "link" in a new tab/window). – Synetech Jun 5 '12 at 17:38
I'm able to reproduce this in Chrome with all extensions disabled. It happens in Chrome on only 1 computer (Latitude E6540, Win 7 Pro). Other browsers on that computer work fine and Chrome on other computers work fine. It happens on and Very frustrating! – Keith Jan 28 '14 at 18:48
I found that the middle button new tab extension fixes the problem even though I'm not using the middle button. – Keith Jan 28 '14 at 19:32
up vote 3 down vote accepted

I also have the same Samsung modelled specified by the OP. It came with an extension installed called Word CaptureX. When I disabled this extension, Ctrl+click worked again perfectly. Strangely, it only didn't work with google sites.

share|improve this answer
I disabled the extension, and at a first look it seems to work properly. Many thanks! – clabacchio Jun 11 '12 at 14:57
I hate "features" like this -- it's one of the reasons that I use Linux. – Vreality Mar 12 '14 at 4:01

It works for my Chrome. And it should be the norm, if I believe this list of keyboard shortcuts.

So you most likely have an issue only inside your installation of Chrome. There is no way to edit these shortcuts, as far as I'm aware. Try to reinstall Chrome, check the extensions which are installed, as they could alter the default behaviour. Try for example to deactivate all of them, and see if you have the issue or not.

Check if it works with another browser, to see if it's related only to Chrome, or if another program is somehow blocking that.

share|improve this answer
As in the edit: it used to work in the other PC, now it doesn't. – clabacchio Apr 17 '12 at 9:47
I Second that. Maybe one of your extensions is using control as a hotkey? – Doomsknight Apr 17 '12 at 10:04
Hey, just to tell you that the issue was related to an extension, as Bob found :) – clabacchio Jul 2 '12 at 13:49

I doubt that it is an extension; it's probably Chrome behaving badly. I used to have this problem too, but only on a select few websites. I'm not sure if the problem was solved (I no longer have it on Youtube) or I simply adapted my behavior by learning to right-click and select "open in new tab" without thinking when needed. Here's the old complaint thread on the Google Chrome forum I participated in.

You might want to check if your middle mouse still does the right thing (if you have a mouse like that to plug in); for me, both CTRL+Click and MiddleClick broke in the same way.

@Gnoupi: Installed extensions on the current Chrome dev are at chrome://chrome/extensions/, not the link you gave...

share|improve this answer
I think mine also works in some pages, but the middle works everywhere... – clabacchio Apr 22 '12 at 13:20 blocks opening links in new tabs via JavaScript. Firefox specifically disallows this type of bad behavior; Chrome allows it. I have to disable all JS on (which loses me nothing but annoying ads :) and CTRL+Click works again.

share|improve this answer

What operating system?

Apparently it works (sometimes?) on Windows. I don't know why Gnoupi said above that it is the norm, though. I cannot find it in the list of Chrome keyboard shortcuts.

share|improve this answer
I'm using Windows 7 – clabacchio Apr 27 '12 at 21:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .