Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm connecting to a Windows Vista computer using my Windows 7 computer. I have a swedish keyboard and whenever I press Alt Gr and 4 combined (should result in a $) the active window gets resized. I have no problem when using Alt Gr to write other special characters such as @ (Alt Gr and 2).

share|improve this question
    
What do you mean when you say the windows is being resized? –  Oliver Salzburg Apr 16 '12 at 14:35
    
By 'resized', do you mean that your current window gets maximized? minimized? restored? Snapped to an edge? And by 'the window', do you mean the active window in the remote session, or the remote desktop window itself? –  Myrddin Emrys Apr 16 '12 at 15:35
    
The active window in my remote desktop session gets snapped to the left edge and if I press Alt Gr and 4 again the width changes between three different sizes. –  Nocklas Apr 17 '12 at 10:59
add comment

2 Answers

Sound like Alt-Gr + 4 is a hotkey used by some utility probably relating to your video driver. Since it only happens to the remote session, I would assume this is installed on the Vista computer rather than the Windows 7.

So, the first place to look is the settings for any utility belong to the video card. Check the tray icons or control panel to see if you can find the utility.

If you can't find which program uses this hotkey, then you can download a free program from http://hkcmdr.anymania.com/ which allows you to see which program has registered hotkeys.

(Note, I have used this program on Windows 7 (64-Bit), but while it works ok, but it looks like it attempts to restart all your active programs in administrative mode in order to detect the hotkeys.)

share|improve this answer
add comment

The Alt-Gr key seems to be handled in a very special way by RDP. This special handling takes some time. Therefore you should wait at least half a second after pressing and holding Alt-Gr before pressing the second key.

Otherwise RDP will execute a different key combination like Win+Up (or something similar) as you have observed.

Another working solution is to use Ctrl + Alt instead of Alt-Gr.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.