Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When you visit google.com you see its favicon ... google
An icon you easily associate with google.

But now why do I also get googles favicon on pages with no favicon. It seems to work like a fallback favicon. This way, having lots of tabs opened (with lots of googles fallback favicon), it's always hard for me to find that one tab that has my google search results.

So is there any way to change this fallback icon so I don't get tabs like imgur

Edit:
Chrome Version: 18.0.1025.163
Mac OS X Lion 10.7.3

I think it's a bug, not a feature. I revisited the page from the screenshot and now I get a globe icon. So I thought wow, it must have been fixed by google already, but just to be sure I typed some random words into google (like f.e. tiger and feiertag) and opened about 15 search results each in a new tab. The last two tabs had the google icon again enter image description here (this and that). When I added a new tab and copy pasted the same url from the "broken icon tab" the icon was a globe again. So I guess there's nothing you guys can do, will have to wait for google to fix it.
At least we know it's a bug now....

share|improve this question
2  
I don't get google's favicon on pages without one. Instead I get a grey browser favicon for these pages. Which version do you use? I use 18.0.1025.16 –  Arvanitis Christos Apr 22 '12 at 11:26
    
thanks, after your message I experimented a little bit more, see my edit –  Allisone Apr 22 '12 at 16:04
    
Would this link help you replacing Google Chrome favicons ? tech-recipes.com/rx/3032/… –  Arvanitis Christos Apr 22 '12 at 18:14
1  
I was able to reproduce the effect on my computer (Chrome 21.0.1180.89 m, Windows 7 x64). AFAIK, the reason is the following: when you click the link to, say, www.antiquariat-feiertag.de in google search results, you first go to a special google redirect page, which has the google favicon, and redirects you to www.antiquariat-feiertag.de (which doesn't have any favicon). That's why your browser thinks, it can use the google icon. –  fiktor Sep 5 '12 at 8:33
add comment

1 Answer

This indeed looks like a bug. Check your installed extensions (if any) in Chrome. There might be one related to favicons, that causes this problem. If in doubt, temporarily disable all extensions. Also try to clear the cache (and if this does not help also history).

share|improve this answer
    
That may be not a bug as I pointed out in a comment to the question. There are 2 reasons: 1. I successfully reproduced the same behavior. 2. There is some logic, underlying this behavior. –  fiktor Sep 5 '12 at 9:08
    
Just because you can reproduce a behavior, it is not necessarily correct. Also I don't see any logic in showing a misleading icon. Especially in a browser from Google, since they would certainly not use their own brand on foreign sites intentionally. Also I cannot reproduce this behavior in the current Chrome version with default settings. So I guess this unexpected behavior is caused by a (probably broken) extension or some other software. Maybe a anti-virus software or some external filter for HTTP content? –  Gurken Papst Sep 5 '12 at 18:42
    
I agree, that this behaviour may be misleading, and needs to be corrected, but it has the following logical explanation. Let's assume you search something in google and press on one of the search results, going to a target page without a favicon. There are 3 pages involved: (G) google search results, (S) google technical page for collecting the statistics and (T) target page. When you on G and click on the link, you first go to S (which has google favicon). S redirects you to T. Since this is some sort of redirect, browser may assume, that S and T have the same meaning and use S's icon on T. –  fiktor Sep 5 '12 at 20:11
    
To better understand, when this behavior occurs, let me describe exact steps and specs I used to reproduce it. I use Google Chrome 21.0.1180.89 (up to date) on a Windows 7 x64 PC. Step 1. Disable all extensions (but don't use incognito window). Step 2. Go to www.google.com in the browser. Step 3. Type www.antiquariat-feiertag.de in the search box and press enter. Step 4. Click on the first link (www.antiquariat-feiertag.de). Step 5. Wait (about 30s) until it loads completely and look at the favicon. I see Google favicon. –  fiktor Sep 5 '12 at 20:29
    
While your assumption could indeed explain the seen behavior, I can not reproduce this behavior by repeating your steps with exactly the same version on Windows XP using a brand new Chrome profile. I guess, most users will be unable to reproduce this, because otherwise the problem (being known since at least april 2012) would have likely been addressed by Google in the meantime. It would be interesting if you can reproduce this with a fresh profile (and also on a system without any software interfering with HTTP connections). –  Gurken Papst Sep 6 '12 at 19:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.