Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I run Ubuntu inside VirtualBox, the networking works the first time I set it up, and then never works again. After a reboot, the network manager applet refuses to connect.

For some reason, the last time I got it working, I had set up a host-only and a bridged connection. I don't remember why, but neither is working anymore. What's a foolproof configuration that won't stop working a week from now?

enter image description here

enter image description here

enter image description here

enter image description here

share|improve this question
    
If you remove one of the network adapters from the Ubuntu VM, is NetworkManager able to connect successfully with the remaining one? –  Steven Monday Apr 17 '12 at 3:43
    
@StevenMonday: Well, initially I only had one bridged, and that worked at first and then stopped working, same as this setup. –  endolith Apr 17 '12 at 13:32
add comment

1 Answer

What are the names of nics given by dmesg? Do they match what are in /etc/network/interfaces?

Also, remove or disable the network manager and see if /etc/init.d/networking will now work. If not try dhclient bridgenic to see if you can get an ip. Network manager and networking service sometimes work in different ways and could cause issues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.