Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After a recent windows update (though may not be the issue), I am unable to run Ubuntu in the virtualbox with full screen mode. I can no longer stretch the window to any resolution. It is locked at 1024x768 in the guest window (Ubuntu). For sanity, I re-installed The Linux Guest Additions. I also tried uninstalling it and reinstalling it even though the script does this for you. No matter what, I can't get past the limited 1024x768 workspace. Furthermore, I noticed that xorg.conf is not in the /etc/X11 folder but I believe this is normal as my other PC running a similar setup also does not have xorg.conf yet scales the guest window of Ubuntu properly to any resolution (including true full screen mode). I have set the guest settings to 64MB video space and also tried 128MB. No difference there. I also tested running Virtualbox 4.1.8 (to try an older working version). Nothing. Now I am back to Vbox version 4.1.12 with no avail.

I am also unable to run the Ubuntu Desktop with advanced effects. Maybe the Linux Guest Additions is not running even though it is installed? How do I verify this?

Any other suggestions?

share|improve this question
FWIW, I installed ubuntu-10.04.4-desktop-amd64.iso into a VirtualBox v4.1.12 VM and full-screen worked immediately after installing the guest additions & rebooting. What distro of 10.10 are you using? Have updates been applied? Could you post uname -a? – irrational John Apr 17 '12 at 17:34
up vote 2 down vote accepted

try with this:

1. Open terminal and enter the following command: 

sudo apt-get update
sudo apt-get install build-essential linux-headers-$(uname -r)
sudo apt-get install virtualbox-ose-guest-x11 

2. Once installation is finished, restart your virtualBox machine. 

3. Go to System -->Preferences -->Monitors and change the resolution of your screen.


share|improve this answer
Thanks! Looks like that would have fixed it with absolute certainty. However, I finally noticed that the install failed without it being very clear. Instead of ending the install with an error message, it states a paragraph before the ending to look into the var/logs for the error pertaining to the install. It was a missing linux-header-generic-xxx file all this time. It's been so long since I had to check for missing dependencies that I guess I got lazy. Thanks for the response. It is the perfect solution for those in the need for this same issue. – Frank Apr 19 '12 at 14:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.