Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am missing a point w.r.t the usage of dohell command. Please point out.

anisha@linux-dopx:~/Desktop/RealTime/downloadedPages> /usr/xenomai/bin/dohell -b ~/Desktop/RealTime/downloadedPages/hackbench
/usr/xenomai/bin/dohell [ -b path ] [ -s server ] [ -p port ] [ -m mntpoint ] [ -l path | seconds ]

Generate load, using an assorted set of commands and optionnaly:
[B]- hackbench if the path to the hackbench binary is specified with -b;[/B]
- nc to send TCP data to "server" port "port" if -s is specified (if -p
is not specified, the port 9, aka discard is used);
- dd to write data under "mntpoint" if -m is specified.

during the runtime of the LTP test if the path to the LTP installation
directory is specifed with -l or during "seconds" seconds.

What's in the directory:

anisha@linux-dopx:~/Desktop/RealTime/downloadedPages> ls
adeosPaper.pdf                                      How To Do Eveything With DD - LinuxQuestions.org_files
AnatomyOfRealTimeLinux.pdf                          How To Do Eveything With DD -
BasicsOfRealTimeLinux.html                          LifeWithAdeos.pdf
dd (Unix) - Wikipedia, the free encyclopedia_files  Makefile
dd (Unix) - Wikipedia, the free encyclopedia.html   mythsAndFactsRT.pdf
FAQsXenomai.html                                    NativeAPITour.pdf
[B][COLOR="red"]hackbench[/COLOR][/B]                                           resourceKernel
hackbench.c                                         RTAI_User_Manual_34_03 (1).pdf
history.pdf                                         xeno-test

Type of hackbench:

anisha@linux-dopx:~/Desktop/RealTime/downloadedPages> file hackbench
hackbench: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.4, not stripped

I tried dohell separately with hackbench and seconds parameter as follows (and it worked properly):

linux-dopx:~ # /usr/xenomai/bin/dohell -b
"/home/anisha/Desktop/RealTime/downloadedPages/hackbench -pipe 100
process 100 seconds" 2
Running with 100*40 (== 4000) tasks.
Time: 2.198
/usr/xenomai/bin/dohell: line 94: 17276 Terminated              while :; do
   $hackbench 1;
/usr/xenomai/bin/dohell: line 94: 17277 Terminated              while :; do
   cat /proc/interrupts;
done > /dev/null 2>&1
/usr/xenomai/bin/dohell: line 94: 17279 Terminated              while :; do
   ps w;
done > /dev/null 2>&1
/usr/xenomai/bin/dohell: line 94: 17280 Terminated              dd
if=/dev/zero of=/dev/null
/usr/xenomai/bin/dohell: line 94: 17281 Terminated              while :; do
   ls -lR / > /dev/null 2>&1;

Then I tried the same with xeno-test as follows:

/usr/xenomai/bin/xeno-test -l "dohell -b
"/home/anisha/Desktop/RealTime/downloadedPages/hackbench -pipe 100
process 100 seconds" 2"
/usr/xenomai/bin/xeno-test -l "dohell -b
/home/anisha/Desktop/RealTime/downloadedPages/hackbench -pipe 100
process 100 seconds 2"
/usr/xenomai/bin/xeno-test -l dohell -b
/home/anisha/Desktop/RealTime/downloadedPages/hackbench -pipe 100
process 100 seconds 2
and also,
/usr/xenomai/bin/xeno-test -l "dohell -b
/home/anisha/Desktop/RealTime/downloadedPages/hackbench -pipe 100
process 100" -T 2
/usr/xenomai/bin/xeno-test -l "dohell -b
/home/anisha/Desktop/RealTime/downloadedPages/hackbench -pipe 100
process 100" -t 2

All of them resulted in the same end results:
What is the way to run this? Please help.

share|improve this question
I ran the same in some other different ways (edit in the question), but nothing seems to be working. – TheIndependentAquarius Apr 18 '12 at 7:47

The last parameter is mandatory.

Either pass a path to your LTP installation if you have one using the -l switch, or a number of seconds to run.

(dohell is a plain shell script, you could just look at it to check how it works.)

share|improve this answer
thanks, I'll try it out. But the above output doesn't mention that the last parameter is compulsory, does it? – TheIndependentAquarius Apr 18 '12 at 0:41
I have edited the question - please see. It isn't yet solved. – TheIndependentAquarius Apr 18 '12 at 7:46
up vote 0 down vote accepted

Of course specifying the time duration is a must, but

xeno-test -l "dohell -b /home/anisha/Desktop/RealTime/downloadedPages/hackbench -pipe 100  process 100 14400"

still doesn't give desired outputs. The problem is in the "parameters" specified with hackbench.
The sub dohell command (with hackbench parameters) works well (individually), but it doesn't work when attached with xeno-test.

I removed the hackbench's parameters ("-pipe 100 process 100"), then it started working with xeno-test.

The following works:
xeno-test -l "dohell -b /home/anisha/Desktop/RealTime/downloadedPages/hackbench 14400"

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .