Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Naive as I was, I convinced my grandparents to replace their XP machines with new Windows 7 computers, since HomeGroups would relief all of their sharing pains.

Was I wrong... Ever since I've been struggling to setup a HomeGroup, a feature which is designed be so simple, that you don't need to be a sysadmin with 12 years of experience (that's me).

I keep hitting the wall, getting the same damn non-descriptive error message. I've tried everything I can possibly think of. If someone can help, I'll greatly appreciate it!

Please note that since both computers are running Danish Windows 7, I've tried to determine the exact corresponding phrasing in English Windows 7's, using Google and my own computer. Where that was not possible, I've translated it.

Basic information

  • Computer A is an HP G5321sc desktop and computer B is an HP Pavilion g7 laptop
  • Both computers are running Windows 7 Home Premium 64-bit SP1 and automatic updates are enabled
  • Both computers are no more than 6 months old

Steps taken

  1. On computer A, I create a HomeGroup, choosing to share everything (documents, printers etc.)
  2. Computer B can see that computer A has created a HomeGroup and offer me to join it
  3. Again, I choose to share everything and enter the password auto-generated by computer A
  4. After several minutes of attempting to join the HomeGroup, I get "An error occurred" in the HomeGroup window and something like "Windows cannot set up a HomeGroup on this computer" in a pop-up (screenshot with Danish wording below) HomeGroup error message in Danish
  5. The HomeGroup troubleshooting tool does not find any problems on either computer

I have tried repeating the above steps but

  • Disabling Windows Firewall on both computers
  • First disabling MS Security Essentials real-time shield on computer A and all Avast Free shields on computer B, later completely uninstalled both
  • Creating the HG on computer B and trying to join computer A
  • Specifying my own HG password with 16 chars, upper and lower-case letters only
  • Specifying my own HG password with 16 chars, upper and lower-case letters and a number
  • Choosing not to share anything on both computers

I have verified the following on both computers

  • Network connection types are set to "Home"
  • IPv6 is enabled and no other elements on the NIC properties are disabled (FWIW)
  • Both the HomeGroupListener and HomeGroupProvider services are running
  • Workgroup is set to "WORKGROUP"
  • Time is accurate
  • Advanced sharing settings are set as follows:
    • Network discovery: On
    • File and printer sharing: On
    • Public folder sharing: On
    • 128 bit encryption: On
    • HomeGroup connections: Allow Windows to manage HomeGroup connections
share|improve this question
    
Does your router support IPv6? Should do if it's fairly recent. –  BJ292 Apr 17 '12 at 23:06
    
@BJ292: The computers are connected through an access point and a layer 2 switch, that doesn't even know IPv4 from IPv6. Honestly, I don't know if the router supports IPv6, but as the HG will never cross the WAN, I don't really think it matters if the router supports IPv6 –  abstrask Apr 18 '12 at 8:10
1  
Ok - can you do an IPv6 Ping both ways between the PCs? –  BJ292 Apr 21 '12 at 6:20
    
Hmmm, not I can't. Not even with the Windows firewall at both ends disabled. If I'm wrong in my statement about whet ever explicit IPv6 support is needed on the access point/switch is needed, can someone please explain it to me? :-) –  abstrask Apr 27 '12 at 15:00
    
Are the PCs close enough that you could cable them together and see if that works? –  BJ292 Apr 27 '12 at 16:35
show 1 more comment

2 Answers

I battled this for hours until I finally disabled the wireless adapter and plugged the laptop into the wireless router via ethernet cable. Voila the homegroup finally connected and once it did it continued to do so after I disconnected the cable and enabled wireless.

share|improve this answer
    
I'll try it next time I visit them. –  abstrask May 21 '12 at 9:11
add comment

I have to ask... Is your network functioning correctly? That is, do they both get an IP address (presumably from a local ADSL modem/router) on the right network?

Try running ipconfig from the command prompt on each computer to check they each have a sane IPv4 address. If your network is not working correctly, sometimes Windows will assign one of those ridiculous 'temporary' addresses. I've seen this on wireless connections sometimes. Most home-user-targeted network devices tend to use the 192.168. network, or possibly 10.0.0.

Once you've ascertained that the net config has sanity, try to ping one machine from the next, using the relevant IP address. Do this both ways.

Then check the name resolution by pinging machines by name. If all this works, then at least you can put the problem into the back of a HomeGroup issue (which I can't help you with because I avoid HomeGroups at all costs!) If you find that there's a fundamental problem with your network config, then at least you have narrowed your search.

[edit]

One more thought. Since they have a desktop and laptop machine, it's not uncommon these days for that kind of setup to have the desktop plugged into a lan port on the modem/router, and the laptop to use the wireless on the router. You want to check your router config and/or which port the desktop is plugged into (some routers have a DMZ port that is intended for firewalling your home network). If this is your setup, make sure both computers are on the SAME network.

share|improve this answer
    
Both computers are on the same subnet. The wireless access point used by the laptop is acting as a bridge. No routing.I can ping the machines just fine both ways and the HG wizard also detects that a HG exists on the network. –  abstrask Apr 18 '12 at 8:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.