Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created a new repository in, generated the password and updated my ~/.netrc with

machine login <email-id> password <password>

As per the instruction in the, I was able to clone the repository using the following command:

git clone<repository-name>/

and after that I added some files to the repository and executed, git add, followed by git commit. But when I executed git push origin master it gave the following error

fatal: remote error: Repository not found

When google'ed for this issue, I found couple of links but the work-around that was mentioned in that didn't seem to work. Any suggestion would be highly appreciated!

UPDATE: I have tried the following work-arounds but unsuccessful:

  1. Update the url in the .git/config to take username and password
  2. Give the username and password in the url in the git clone command
  3. Update username and password with global git config command
share|improve this question
Please edit your question to include the workaround or any other solutions you've already tried. Otherwise, we may answer with one of these, providing no additional help! – iglvzx Apr 17 '12 at 21:48

Did you changed the repository type to git in Admin -> Source of your project? Or did you choosed git as type? The .netrc should look like this, not in one line.

login <email-id> 
password <password>

what is in your .git/config ?

[remote "origin"]
    fetch = +refs/heads/*:refs/remotes/origin/*
    url =<PROJECTNAME>/
[branch "master"]
    remote = origin
    merge = refs/heads/master
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .