Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to use emacs in the terminal, but in Ubuntu 11.10 the bash terminal already has many Alt started shortcuts, how can I handle that?

share|improve this question
up vote 5 down vote accepted

You might want to consider using a proper terminal emulator instead of the gargantuan kraken-sized beast Gnome ships with. I suggest urxvt, or sakura if gtk is a must.

That being said, Emacs technically doesn't use the Alt key. It uses the "meta" key, which happens to be mapped to the alt key on modern systems, but that isn't mandatory. For one, you can use any A-<whatever> combinations by hitting ESC and then <whatever>. This works pretty much on anything Unix.

Alternatively, map the meta key to something else. This is explained here.

share|improve this answer
    
I don't want to press ESC before E|A|B|F to navigation, it's not produtive enough. But I cant find any information about how to transfer ALT to Capslock to solve the bash problem. I'm using Ubuntu then I cant transfer the ALT key to the Super Key because it is already used to show my "start menu" in Ubuntu and I like that. – MaikoID Apr 19 '12 at 22:20
    
Easiest and fastest way, get a proper terminal that doesn't interfere with the alt key. – mkaito Apr 19 '12 at 23:10

Somewhere inside the Terminal->Edit->Properties, there is an option to disable the Alt prefix for menus, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.