Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I definitely know how to change the home page in Internet Explorer (Tools -> Options -> General). The problem is, no matter what I put there, it never changes. Stop/restart Internet Explorer and the old home page is back.

I did some research to see if there is a registry key that I could tweak to get the home page to set properly. I changed the start page registry key and refreshed the view and the start page key (without even restarting regedit) was reset back to its original value.

Now I'm a little concerned. Maybe there's some virus I can't detect on my system?

Internet Explorer 9.0.8112.16421
Windows 7 Pro SP 1 x64
share|improve this question

migrated from stackoverflow.com Apr 18 '12 at 14:55

This question came from our site for professional and enthusiast programmers.

    
Is the default home page malicious, or advertising, or something that would indicate it's a virus? –  Lynn Crumbling Apr 18 '12 at 14:57
    
it's avg.com - ironically, an antivirus website. but it contains a guid in the url. prolly identifies me as me. –  horace Apr 18 '12 at 15:15
    
Is this 32 or 64 bit Windows 7? –  CharlieRB Apr 18 '12 at 15:44
    
windows 7 sp 1 64 bit –  horace Apr 18 '12 at 15:53
    
@horace: It's part of the new user restrictions. They're meant to prevent spam and will disappear once you earn 10 rep. –  Dennis Apr 18 '12 at 20:05

5 Answers 5

up vote 4 down vote accepted

Ok, folks. Here's what I had to do:

  1. Go to the Control Panel -> Unistall programs and remove avg search tool: that's where it was, even though it was in my IE -> Tools -> Manage add-ons, I couldn't edit it because of the disabled 'remove' button when clicking on the avg search tool add-on. (also, since this was a clean new install of Windows 7, I'm not sure how it got there in the first place. Never installed/used AVG in my life.)
  2. Go to the registry and edit the HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes and delete the DefaultScope entry
  3. Now go to the Tools -> Options in IE and set the homepage to your heart's desire.

Simple as that.

To Lynn Crumbling for pointing out the AVG forum that led me to the regedit fix. But without removing the program from the Control Panel, this would simply do nothing, and come right back. Prolly a background process that manages the registry and crams the key back in place no matter what you do. Very clever, AVG.

<soapbox>

this "avg hijack" is a commonly known and very unpopular "feature". Lots of people hate this kind of behavior, and it comes down to people like those on the AVG forum and myself to fix it all by our lonesomes.

if I started writing software that behaves like this, I'd get lynched.

</soapbox>

share|improve this answer
    
FYI, you can answer your own questions. :) –  iglvzx Apr 18 '12 at 23:48
    
well, at first, superuser wouldn't let me cuz i figgered it in under 8 hours, and they don't letcha answer your own question in under 8 hours. who'd'a thunk? i just fixed up the question, comments and my answer. thx! –  horace Apr 18 '12 at 23:59

Check out this thread:

http://forums.avg.com/us-en/avg-forums?sec=thread&act=show&id=188650

Sounds like your issue.

Specifically, the one poster says: "Thanks to help from others on the forum, I found the small Settings link and disabled it successfully."

See if you can find it too.

This page discusses it more thoroughly: http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=188955#post_188955

A few users mentioned on forums they would like to disable the AVG default new tab page (which includes AVG secure search). This feature could be disabled by clicking the Settings link in lower-right corner of the newly opened tab (note the Settings link is not available on home page, it is present only on newly opened tabs) as seen on this screenshot. - Modify the Show AVG Secure Search Box on new tabs in the browser as you wish. - Click OK to save your configuration.

share|improve this answer
    
been looking thru this article. interesting.. tried a couple things but no go. also: the quote about 'disable avg search on new tab' is referring to firefox. my prob is for ie. i get avg search on a new browser window when starting ie. new tabs are clean. –  horace Apr 18 '12 at 19:16
    
also, i just tried editing: "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes" to remove the DefaultScope, but after deleting it, the %(& thing just comes right on back. –  horace Apr 18 '12 at 19:18
    
thanks lynn.. the avg forum was a push in the right direction, but it took a little more oomph. see the answer i posted. –  horace Apr 18 '12 at 23:53
    
Just happy to see that you found a solution :) –  Lynn Crumbling Apr 19 '12 at 2:13

With all the viruses and malware\spyware\adware floating around the Internet your problem could be caused by an infection. Some of these hijack your home page.

Do a complete virus scan and clean. Then run Malware Bytes or SpyBot S&D to make sure there isn't anything else (malware/spyware/adware) messing with your system. A free online scan at eSet just to make sure its all gone might be a good idea.

share|improve this answer
    
well, i just installed the os a couple days ago and haven't really done a bunch on it since. but since i did mention that it might be a virus, should do a deep scan first, huh? –  horace Apr 18 '12 at 15:16
    
Especially if you have no current protection. –  CharlieRB Apr 18 '12 at 15:42
    
just finished a deep scan and flash scan with malware bytes - all clean. –  horace Apr 18 '12 at 15:52

In addition to viruses, many of the toolbars that you can download and install into IE will also hijack your homepage. Some will politely ask you if you want to reset it to their homepage and others will just do it without telling you. So if you added any toolbars, check their configuration options as they will often override IE's defaults with their own settings.

share|improve this answer
    
good thought. no toolbars installed. still looking for the "culprit" –  horace Apr 18 '12 at 15:29
    
When checking for toolbars and other add ons, go to Tools->Manage Add ons. Check all the sections there, and disable anything you can that you know you don't use –  Canadian Luke Apr 18 '12 at 16:59
    
interesting. on 'Search Providers', AVG Secure Search is the default, enabled, and the 'remove' button is disabled for this selection. seems someone does not want me to remove avg as a search engine in ie.. –  horace Apr 18 '12 at 17:20
    
I've seen several Anti-virus apps do that. McAfee tries to do that to me everytime I install a new update. At least it asks me and lets me opt out of that. –  BBlake Apr 18 '12 at 20:59
    
bblake: i never had an "opt-in"/"opt-out" offer. not even sure how avg was installed in the first place. also, this was no trivial "change". see the answer i posted. –  horace Apr 18 '12 at 23:52

Check in your %systemroot%\system32\drivers\etc\hosts file to see if some odd network path has been set. A malicious entry in this file can route your browser through arbitrary sites...

share|improve this answer
    
only things not commented out are two lines: "0.0.0.0 .psf" and "0.0.0.0 psf" –  horace Apr 18 '12 at 23:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.