Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install pygtk2 on centos 5.8 for use with python 2.7

installing yum install pygtk* works only for the default python 2.4. I tried compiling pygtk2 from source but it does not configure because

configure: error: Package requirements (pygobject-2.0 >= 2.21.3) were not met: Requested 'pygobject-2.0 >= 2.21.3' but version of PyGObject is 2.12.1

The repos only have version pygobject2-devel-2.12.1-5.el5 already installed and latest version

Has anyone had any luck installing this?

share|improve this question
add comment

2 Answers

You can install Python 2.7 and all other libraries you need in /opt, building from source, so they won't clash with anything of Python 2.4.

share|improve this answer
add comment

Either rebuild the newer pygobject from a Fedora SRPM, or install it from source in a different prefix (same one as your Python install though).

share|improve this answer
    
and that needed a newer version of glibc. Maybe I can install pygtk 2.10.1 instead of the latest one. That seems to have dependencies met. –  garg Apr 18 '12 at 19:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.