Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My home system is running Windows XP Pro set up with a non-privileged account for each family member.One of the primary uses is storing all our photos, currently under "Shared Documents". As our photo collection has grown we've started running out of room on the C: drive. I've installed a second drive, D:, and found that folders on it are readable by all, but not writable. For example, if I download pictures from my camera to D:\photos, my wife can see them from her account, but cannot edit the files. The only advice from the OS regarding sharing folders is to "drag it to the Shared Documents folder", which simply copies the files onto the C: drive again.

How can I make a folder on D: work like the Shared Documents folder?

share|improve this question

This can be done, but you have to edit the registry. If you haven't done alot of this, make sure you backup the registry and your files ahead of time.

Open Regedit.exe Navigate to: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Explorer \ User Shell Folders

Edit the Common Documents key to point to the new location (D:\SharedDocs)

To move the subfolder, you will need to create Reg_SZ keys called CommonMusic (no spaces), CommonPictures and set the value to a new location (eg: D:\ShareDocs\Music)

More here

Note - you need to move the data yourself. Perhaps copy it over before you edit the registry then delete the old copy once you know it works.

share|improve this answer

Open an explorer window, right-click the D drive, choose Properties and switch to the Security tab. Modify the group that your family belongs to so that they have write permissions (not only read) for the drive.

Note that the above will only make the D drive accessible for your family while sitting on that computer. If you want to make the files available over the network you need to share the drive or folder (same dialog as above, under the Sharing tab).

For some guidance, see

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .