Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When pressing tilde in Windows 7, using a Swedish keyboard layout, the computer waits for a second key to be pressed. The reason behind the wait is to allow users the ability to construct characters such as ã and ñ, which I never type. Can I disable this so that pressing tilde once actually generates a tilde?

share|improve this question
I assume you want to otherwise keep the Swedish keyboard layout though, right? Probably best to make this explicit. – Shinrai Apr 19 '12 at 16:47
Yes, I to preserve it otherwise. – Jonatan Apr 19 '12 at 16:48
up vote 12 down vote accepted

First, download and install Microsoft Keyboard Layout Creator. Then, follow these steps:

  • open KLC and go to File -> Load Existing Keyboard...
  • select your keyboard layout and click OK
  • when the layout has loaded, double-click on the key that produces the tilde character

enter image description here

  • in the new window, click "All..."

enter image description here

  • find the combination that produces the tilde character and uncheck the "Dead Key?" checkbox

enter image description here

  • click OK
  • optional: go to Project -> Test Keyboard Layout to make sure the key behaves the way you want to
  • optional: go to Project -> Properties and change the layout name and description
  • go to Project -> Build DLL and Setup Package, wait for the process to complete and click Yes to open the directory where the setup files are located
  • run the setup.exe file to install the new layout
  • finally, go to Regional Settings in Control Panel (or use the Language Bar) to switch to the new layout
share|improve this answer
Exactly what I wanted, thank you very much to the explanation! – Jonatan Apr 19 '12 at 17:17
Been pressing ~ twice for ages, now I can use it as it should, thank you! After applyling this fix any application running must be restarted to use new layout. – PeterM Jul 23 '15 at 9:51
Under Windows 10 I had to restart the system (obviously) for the new keyboard layout option to appear. Indrek - you, sir, make the world a better place. – Mikolaj Radwan Jan 31 at 9:02

Visit The Microsoft Keyboard Layout Creator web page and download MSKLC.EXE (10.1 MB).

Some of this program's features allow you to base new layouts off of existing ones. (This means that you can take the current Sweedish keyboard layout and remove the current character/action and replace it with a tilde.)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .