Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For months now I have been plagued with issues regarding Flash content in my browsers. Regularly when I try to load (e.g.) a YouTube video, the browser will hang and I have to kill plugin-container.exe to regain control. Also, an issue which always occurs is a 3-5 second delay when I switch to full-screen video mode on YouTube, BBC iPlayer, or any other streaming Flash video.

I have searched for solutions to no avail and have tried disabling hardware acceleration, clearing my cookies, new browser profiles, reinstalling Flash itself, etc.. I am very much open to suggestions now, please.

My system info is: Windows 7 x64, 16GB RAM, 3.2GHz Intel quad core, 2 x Nvidia GTX 580 in SLI. I doubt it's a performance issue. I am running Comodo Antivirus/Firewall but disabling this does not help, either.

Any help is massively appreciated. Thanks.

share|improve this question
    
Have you tried upgrading your graphics drivers? –  iglvzx Apr 20 '12 at 2:50

1 Answer 1

up vote 0 down vote accepted

It's the 580 and the most-likely antiquated drivers you have going. Also Anything less than the absolute latest flash version. (11.2.202.233)

I had this same exact problem and you're not alone. This is definitely because of the two above mentioned items.

Good news is, I haven't had any problems since I updated flash, and I'm running 301.24 nvidia driver which is the current latest as of this writing. Be sure to do a clean install, where at the very least you install all subsequent versions (if you've been installing over, you'll have to restart your computer once for every time you installed over - very stupid imo.) and then use a piece of software called DriverSweeper which helps find left over nvidia elements and removes them.

share|improve this answer
    
I had the latest Nvidia drivers, and had been keeping Flash up to date over the past few months (the duration of this problem), however the latest Flash update (the one you mentioned) seems to have helped. Now there is only a tiny delay. Thank you! –  Jeff Buxton Apr 21 '12 at 1:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.