Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not talking about adjusting screen brightness through power management (this is a laptop), I'm not talking about how the screen brightness setting may be different between 'plugged in' and 'battery powered', and unplugging the laptop will suddenly change the brightness. I'm talking about:

I have a Dell XPS 15 (L502X), and with intell hd graphics driver installed (from a vanilla win7 64 bit install), I start to see a brightness change. (This is also before the nvidia driver install).

I set my desktop to black, and open notepad, fullscreen. Now the entire screen is a bright white. I then alt-tab back to desktop, all black.

This is the interesting part:

I alt-tab back to notepad (all white, fullscreen), and the brightness of the white slowly, every so slightly, incrementally steps up (less than even one brightness adjust as you would do via the power settings). Then you swith back to the black desktop, and barely you can tell it steps back down (the backlight on the black grows a bit darker). It is a small change, but noticeable in a dark room. Again back to white, and a step up to a brighter white.

It. drives. me. crazy. :)

It is very annoying googling for info (everyone has something about power management). I can't find any setting in the intel hd graphics properties that affects this. Oddly enough, I have an older install of windows on this same machine which doesn't do it, I fixed it once about a year ago and I can't remember how I did it (I work on quite a few pc's, I THOUGHT I tweeked something in the intel hd graphics properties, but nothing seems to stick this time).

  1. What is this feature called?
  2. How do I disable it?

EDIT

This does behave a lot like the automatic brightness adjustment that my smart phone exhibits. Ironically, that annoyed me as well (fixed with root and app)

I have tried to disable this feature, but here is a screenshot of my "Power" tab:

enter image description here

// The brightness feature is missing

I'm going to check what this tab looks like on my other disc (where I believe i once 'fixed' this)

EDIT 2

Turns out it was in the same view, but you have switch to change the power source to 'on battery' and disable "DIsplay Power Saving Technology"

enter image description here

Thank you.

share|improve this question

4 Answers 4

up vote 5 down vote accepted

I'm not seeing this effect myself (white/black Paint windows), and you've probably tried this already, but how about the Automatic Display Brightness setting in the Intel HD Graphics Properties (Advanced mode)?

Screenshot of setting
Click for full size

Especially if it's in a dark room, it sounds like what a smartphone's 'light sensor' would do: when it's darker, turn down the brightness. When it's lighter, turn up the brightness. In a dark room, the increased brightness from a white screen might cause the sensor to see the whole room became brighter, a kind of feedback loop. And when the screen is black, the whole room becomes darker, causing the screen brightness to be lowered.

share|improve this answer
    
I think you're on the right track. See my edit/update. –  payo Apr 20 '12 at 6:46
    
Well suddenly it stopped, I'm in the process of running all updates and now I noticed it stopped doing it. Sheesh! I wish I had a handle on this thing. Couple notes: I tried the latest drivers from intel - they wouldn't install saying only oem's were allowed, also, I haven't checked how the prop tool looks on the other drive yet. Some other time. I still think you're right tho, giving you the answer. –  payo Apr 20 '12 at 7:20
    
see my answer's 2nd EDIT, the issue was found –  payo Apr 21 '12 at 3:50
    
That's interesting, I have that option on Plugged in as shown in my screenshot...perhaps a different driver version. –  Bob Apr 21 '12 at 4:35
    
The problem is that the setting won’t stick and will revert. –  Synetech Dec 2 '13 at 4:12

Intel’s “power-saving feature” is indeed extremely aggravating. It is supposed to reduce power consumption, but all it does is to fade the screen in both brightness, and more importantly, contrast, but only when the display is primarily dark.

The problem with disabling the function in the Intel Media Control Panel as Bob has shown is that it just doesn’t stick. It gets reset to being on and in the middle when you reboot, and even under other circumstances (like changing the screen resolution, going into and out of standby, etc.)

I’ve searched high and low for a way to permanently disable this “feature”, and have eventually found a more-or-less satisfactory solution that works for most systems that use an Intel video-adapter (regardless of make or model).

  1. Open the Windows Control Panel
  2. Select Power Options
  3. Click Change plant settings
  4. Click Change advanced power settings to open the Power Options dialog
  5. Expand the Intel(R) Graphics Settings branch (Figure 1)
  6. Set it to Maximum Performance
  7. Click [OK], close, etc.

The screen brightness and contrast should no longer “adapt” to the overall brightness of what is being displayed.

You may as well change it for all of your power plans (Figure 2), even Power Saver because it does little to reduce battery power and only makes the display ugly.

It should be noted that this is not a perfect solution. It is analogous to moving the slider in the Intel MCP to Maximum Quality; there does not seem to be a way to outright disable it like un-checking the Disaply Power Saving Technology box (Figure 3). It may not be ideal, but at least it works and does not need to be repeated constantly.


Figure 1: Intel-specific power-plans settings

Intel-specific options in Power Options dialog

Figure 2: Make sure to edit each power-plan

Power Plan drop-down in Power Options dialog

Figure 3: Intel’s “power-saving features”

Screenshot of power-saving page of Intel Media Control Panel

share|improve this answer

For Dell LCD, you need to turn off the "Smart Energy" and/or "Dynamic Contrast" features! These 2 will auto adjust your brightness. Look for it on the LCD screen menu - the hardware, NOT on the software!

share|improve this answer

After tons of searching I found the correct option in advanced power options

Display>Enabled Adaptive Brightness

Using win 8.1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.