Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Word 2007. I created a massive (300 page) Word document by copy-pasting text, tables and images from various external (Word and Excel) documents. This might not have been the best way but I needed a quick sample document which I managed in the end.

The problem is, along with the text and data, some links got copied over to the new Word document too. I don't want any external links in my Word document; I want it completely separate from all the documents I copied data from. So I broke links by going to the 'Office Button' > Prepare > Edit Links to files, selected all links and clicked 'Break links'. All existing links got broken, but one remained:

enter image description here

I have NO idea what this NULL source file is and am not able to break this link. When I try to update all my fields by doing ctrl+A and F9, I get the following error message:

enter image description here

This is really frustrating, as I just cannot locate the faulty link. I've scanned through my entire (300 page) document and still couldn't find a way to locate where this 'chart' object is.

Has anyone else experienced a similar problem in Word 2007/2010? Any help on how to locate the faulty link or break it would be greatly appreciated!

share|improve this question
    
Have you tried to modify the link, save it and then remove it? Also, how about looking in the Visual Basic editor to see if you copied something there. Use Atl+F11 to access the Visual Basic editor. –  CharlieRB Apr 20 '12 at 17:56
    
@CharlieRB what do you mean by "modify link"? I tried assigning some random source and then breaking it again, but that didn't work. I also accessed the Visual Basic Editor and it seems to be empty (there's nothing there that tells me an extra object is present). Any ideas? I'm perplexed –  prrao Apr 20 '12 at 18:23
    
By "modify" I was thinking exactly what you tried. Other than just wanting it gone, is there any negative effect to leaving this one link? –  CharlieRB Apr 20 '12 at 18:34
    
Every time I update my fields, I have to wait an additional few seconds because it takes that long for the "linked file not available" error window to pop up. The fields update perfectly fine, but the annoying faulty link window keeps appearing each time. I wish there was a way to locate the faulty object so that I could at least try manually fixing it (maybe recreate the table/figure) or something –  prrao Apr 20 '12 at 18:42
1  
I don't know of a "field checker", but if my answer doesn't solve it, we can look for some VBA code to try to identify it. –  CharlieRB Apr 20 '12 at 18:47

8 Answers 8

up vote 7 down vote accepted

I fixed this problem relatively easily by going to to the 'Office Button' > Prepare > Edit Links to files, and selecting 'Change Source'.
enter image description here

I basically changed the source to a random blank Excel workbook within the same directory as the word document. After this, I carefully scanned through all Excel charts in my document. The faulty chart was caught red-handed and showed up as a blank Excel plot, as follows:
enter image description here

I just had to delete the chart and the link automatically broke.

SUMMARY: Break all links, find that there is one NULL source (or many) in the document, and then specify a pseudo-source Excel sheet. Only the chart with the external link shows up as a blank chart. All correctly copied charts that are clean (not linked to the external workbook) have no such issues.

share|improve this answer
    
Great job documenting what you found. This will undoubtedly be helpful to others. –  CharlieRB Apr 24 '12 at 15:13

This thread seems to describe a very similar problem : NULL Source file in my template.

Q: my template appears to have a link to a source file that when looking at File/Info/Links to Files shows a NULL source file and its name is CHART.

A: Found it was a pie chart linked to an Excel spreadsheet - deleted the pie chart and bingo link removed

One way to search your document is to do Find (Ctrl-F), "Go To" tab, and search for a chart object. For example :

image

share|improve this answer
    
That link doesn't explain how the pie chart that was causing the problem was found! Also, my document has no pie charts. All it has are tables (copied from Excel) and images (copied from PowerPoint) Since my document is so large is there a quick way I could pinpoint which (among hundreds of Excel tables/PowerPoint images) is causing the problem? –  prrao Apr 23 '12 at 15:36
    
My guess is that you must have copied a chart without knowing it, and now it is close to invisible. I have added above one way to search for charts. –  harrymc Apr 23 '12 at 16:43
    
Thanks for the tip. I used ctrl+F and looked for the chart as you showed, but no objects are present in the document!! I changed the drop-down from 'Excel Chart' to 'Any Object' and it does not find any objects in the entire document. All other entries (fields, headings, bookmarks etc.) are found with no problems. Do you think it is a bug? I've been stuck on this problem for a month. At this rate, I'd have been better off recreating the document from scratch –  prrao Apr 23 '12 at 17:14
1  
This looks like a mess-up by MS. In such cases I usually try to SaveAs in an old format that doesn't have these newfangled objects. You could try to SaveAs (1) 97-2003 doc (2) OpenDocument (3) rtf (4) Works (in descending chronological order). If you get rid of the error you can SaveAs again as docx. –  harrymc Apr 23 '12 at 17:38
1  
I suggest the next round to take regular backups, because you might again copy the same bit and recreate the same link problem. Try to merge/copy without using links. –  harrymc Apr 23 '12 at 18:36

I know your document has a lot of pages, so I am hoping this will work because it's an easy fix. Hopefully the cut and paste wont choke on it.

  1. In the existing document, select all text using Ctl+a
  2. Right click and select copy
  3. Open a new document
  4. Right click and select the "Text Only" paste option.

This should paste only text (without links) into the new document.

share|improve this answer
    
Thanks for the suggestion, I really appreciate it. But the problem is my large document already contains tons of cross-references and hyperlinks for figures, tables and so on, so the text only option will make my life hell! –  prrao Apr 20 '12 at 18:49
    
I guess the best way would be to use some VBA code to remove only external links and retain all internal links within the document. Do you happen to know of a way to do this? –  prrao Apr 20 '12 at 18:52
    
Sorry. Misunderstood "I don't want any external links in my Word document" as no links at all. We'll have to look for the VBA code. –  CharlieRB Apr 20 '12 at 18:59
    
I found the solution and posted it as an answer. I tried modifying the source to a blank Excel Workbook. This led me to the exact chart that was causing the problem; it showed up as a blank plot unlike the other (correctly copied) plots. Thanks for your help! –  prrao Apr 23 '12 at 20:48

For me, replacing the source chart object with a blank chart did not work. The problem ended up being the fact that I was tracking all changes made in the document as part of a revision process.

If you are using track changes, a deleted chart object stays within the document, even though you can't see it anymore. This also means that the Link, NULL or not, will stay in the document, and give you those annoying warning messages if the link is broken.

The solution was to turn on visibility for all changes, find the chart deletion "change" and accept it, thus deleting the chart for good.

share|improve this answer

FINALLY figured out a simple way to break the link!

Under the "Start Mail Merge" button, just select "Normal Word Document." I saved & closed the document and re-opened it, and this time there was no prompt about placing data from my database. The link had been broken.

Very simple to do, but it's ridiculous that Microsoft changed it so much from previous versions of Word that we couldn't find it at all.

share|improve this answer

I had the same problem and I fixed it by cutting every chart and pasting it back in with the correct paste option. Sometimes this didn't seem to work but repeating this procedure fixed it anyway.

share|improve this answer

[The hard way] Follow these steps:

  • Make a copy of your file.docx: File-copy.docx
  • Open the copied file.
  • Remove the second 150 pagesand save.
  • Reopen to see if the link is in the second 150 pages.
  • If yes, make another copy of the original file and remove half of the second 150 pages.
  • Continue halving the pages to find which page the link is in.
share|improve this answer

Once you have found which object has the null source, you can cut the object, then paste it back into the same spot.

After you paste select the drop down in the corner( "Paste Options") and select an option that does NOT link it to the original file, either of the options on the left with the red arrows under it.

screenshot

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.