Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My work machine was recently updated from Windows XP 64-bit to Windows 7 64-bit. I have found a few odd things that I can not figure out why they are occurring. If I type in Notepad.exe or RegEdit.exe from the Run diaglog the applications will not launch. When executing RegEdit.exe from the Run dialog the UAC does display asking for admin privileges, but the application never launches. Also, if I go to the Start menu and click on Notepad from there, Notepad never launches either.

Other programs seem to be okay, like mspaint, wordpad, etc. Now, if I launch Notepad or RegEdit from C:\Windows\SysWOW64 then these applications will run, though I think these are the 32-bit version and not the 64-bit version. I am not sure what is going on. Has anyone seen this behavior before and how to fix it? I have Windows 7 64-bit at home and I don't have this issue. I even copied Notepad.exe from home and place it in the C:\ folder and tried to launch it from there and it still doesn't work.

Regards, Mark

share|improve this question
    
If your PC is an old hyperthreading processor system, enter the bios and disable hyperthreading and save changes on exit of bios, see if they work properly now. –  Moab Apr 21 '12 at 17:42
    
Moab, thanks for the suggestion. I did disable the hyperthreading to see if that would work, but unfortunately it did not. The work station has a Intel Xeon CPU (W3550 @ 3.07 GHz). –  lordhog Apr 23 '12 at 17:57
    
Does it show in task manager after a launch attempt? –  Moab Apr 23 '12 at 21:19
    
Moab, no, I don't even see it pop in and out in the Process tab of the Windows Task Manager. If I attempt it execute it with Run As Administrator, I do see dllhost.exe appear then disappear in the Process list though. I can't be sure, but what looks like "consent.xxx" runs right before dllhost.exe, which is probably the UAC that appears. Also, I looked through the Event Viewer for any information, but I didn't see anything. –  lordhog Apr 24 '12 at 22:36
    
Run the System File Checker...support.microsoft.com/kb/929833 –  Moab Apr 25 '12 at 0:13

1 Answer 1

It sounds to me (guessing) that the OS is still trying to access the 32 bit versions of the progams. I would try modifying your PATH variables (go to start, type path, and Edit the System Environment Variables... At the bottom, under Path, add C:\Windows\SysWOW64 (remember to reperate entries with a semi-colon (;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.