Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use to be able to mount a directory on my debian virtual machine without any problems. Today however, when I try to run this:

sudo mount -t nfs 10.1.1.45/home/dev /Users/myusername/LocalServer 

I get the following error :

mount_nfs: could not parse file system specification

Any ideas whats happening here?

Thanks.

share|improve this question

1 Answer 1

You're missing a colon in 10.1.1.45:/home/dev.

share|improve this answer
    
Good catch! But after trying that, I'm now getting mount_nfs: can't mount /home/dev from 10.1.1.45 onto /Users/myusername/LocalServer: Permission denied. –  az101 Apr 20 '12 at 23:35
    
I had to use insecure in the export options here because the mount request doesn't come from a (not-really-)"secure" port (defined as one < 1024, which Unixes only allow root to bind() — no such restriction exists on Windows, which makes it largely historical and pointless). –  geekosaur Apr 20 '12 at 23:46
    
Pointless on a single user system like Windows, yes, but Unix was designed at the outset as a multiuser system. You don't want non-privileged processes binding to, say, TCP port 25 and slurping up everyone's e-mail. –  Kyle Jones Apr 21 '12 at 1:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.