Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Linux Mint 12 - the Gnome version - on a new Lenovo Thinkpad L520 for a friend.

It's running kernel 3.0.0-12- generic.

When I booted - either into the live CD, or into the installed system - it would get stuck on this message:

bio: create slab <bio-0> at 0

I eventually figured out I could get it to work with this boot flag:

acpi=off

So I booted into the live CD with that flag, installed it, mounted the new system from the live CD and chrooted into it, added the acpi=off flag and ran update-grub.

It all boots fine now, but obviously there's no ACPI. It doesn't report battery status, and the one time my friend unplugged it it seemed to turn off immediately.

Is there some way around this? Can I somehow determine whether this laptop would work in a more recent kernel? Or can I somehow insert ACPI support in at a later time, after boot?

share|improve this question
    
I had similar issues on a different machine. What helped me was to add processor.nocst=1 instead of turning the whole acpi off. –  choroba Apr 21 '12 at 14:25
    
Unfortunately that had no effect. Since I had this problem across distros maybe I need to find some kernel folk to ask.. –  Cerales Apr 25 '12 at 3:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.