Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have cable internet service through Charter Communications and feed two desktop computers through a Linksys RP614v3 router. One system is my wife's running WinXP Home Edition and the other is mine, running Vista Home Premium (sp1). I have port forwarding configured in the Linksys so I can access the Vista system remotely using TightVNC. Initially, it worked great and I was able to remotely tend email and access local files while out of town for work.

Lately, the cable internet service appears to flicker intermittently and upon return, my Mailwasher program loses ability to access the net and I've been unable to make the remote connection. When I reset the port forwarded for email in the router control panel, Mailwasher functionality returns but as I'm home when that happens, I have no easy way to check remote access until the next time I'm on the road or at work.

I'm at my wit's end -- the TightVNC client accesses fine from my wife's system from behind the modem/router setup but I don't know how to maintain whatever gets reset when I fiddle with the control panel and the need to do so at all is new. I accessed it fine for a week off and on while out of town a month ago and now I can't leave home and access it from work an hour later.

share|improve this question
    
are you sure that's a Linksys product? i think you've got the make or the model wrong -- RP614 is a Netgear model. (i bring this up because my suggestion would be to try 3rd-party firmware like DD-WRT -- but you'd need the right model# to figure out if that would work.) –  quack quixote Jan 18 '10 at 7:40

5 Answers 5

First you have to determine whether your "Cable Modem" has a firewall.

To circumvent connection issues when consumers plugged in a new computer without power cycling the modem, Cable Companies pretty much made a 1 port modem/router with a firewall. So consumers could just swap ethernet cables. Check the WAN ip address of the router and make sure it's something different than a 192.168.X.X.

If not, you have to log into the modems web interface (192.168.1.1 or whatever yours is) and turn off the firewall or forward all unsolicited traffic to the router.

I've seen this in westell modems, global link modems, cox cable modems. It's worth a shot.

share|improve this answer

Have you tried changing the port over which it runs? Perhaps Charter is blocking the normal VNC port?

share|improve this answer
    
I hadn't tried that until reading your question ... and before trying that, I wanted to make one more attempt to access it with the normal port so reset the router's port forwarding while home at lunch time today and sure enough, once back at work I was able to access the system just fine. An hour or so later, it was the same story all over again with no access and when I arrived home from work, I had to switch the settings again so Mailwasher could once again do its job. I don't know what exactly I'm missing but can't shake the notion that it should just work ... –  user11189 Sep 15 '09 at 22:06
    
@GFilkins - I'm at a loss :( –  warren Sep 16 '09 at 0:53
    
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. –  Diogo Aug 9 '12 at 20:11
    
@Diogo - that's true ... now. It wasn't when I originally posted this answer, though - there wasn't a comment feature that I can recall 3 years ago. –  warren Aug 9 '12 at 20:38

Have you checked your port forwarding rules to be sure you are forwarding to the right IP addresses? You may have gotten a different IP from your DHCP server.

share|improve this answer
    
Yes, after the first few failures, it occurred to me that if the IP address had changed, the forwarding was doomed to fail. The IP has essentially remained static -- if it's changing, it's changing back again before I look at it. I've gone to using TeamViewer from teamviewer.com and while it scales the screen unattractively, it doesn't need port forwarding. It's a passable workaround for now . . –  user11189 Sep 30 '09 at 10:17

I would configure your router to use a non-standard port for the port forwarding. I know ISP (Cox specifically) block commonly used ports (25 mail, 80 web, etc) from being used. However, from your other comments, this doesn't seem to be the case, but it wouldn't hurt.

Additionally, I would set up your machine to have static internal IP or reserved DHCP address ssigned to it by the router. This way, you can be reasonably sure that you won't have to reconfigure your internal network constantly.

Also, you may want to be sure that your cable modem is getting the same external IP address from your ISP. With Cox, my external IP changes constantly, and changes drastically from 24.x.x.x to 79.x.x.x to 98.x.x.x. I've seen it change a few times in just a few weeks, followed by periods where it's pretty stable for months, then start changing constantly again.

if you find that it keeps changing, then you can use a service like dyndns.org to have a constant url to reach your site each time the address changes.

share|improve this answer

Not sure if you fixed it by now. My linksys was having a problem keeping a port open when I used single port fowarding, they fixed it in a firmware update. However the fix before that was to use range port fowarding and use the same number for both fields in the range.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.