Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I keep on getting this error even though I have uninstalled Python on my machine. I thought that this could be related to Java, so I reinstalled Java but it did not work.

Also, what is a UC_Image_PATH environment variable?

enter image description here

share|improve this question
up vote 1 down vote accepted

This question on Stackoverflow seems to suggest that the culprit is the update tool from the GlassFish Java Application Server.

Similarly this Oracle forum page seems to state that a few ways of getting the problem resolved as

I believe what may be causing this is Glassfish. So far, no more error messages after uninstalling Netbeans, then reinstalling the SE version without the bundled Glassfish and Tomcat servers.

Alternatively the same thread states:

After spending tons of hours i finally find a solution to this problem. The solution was the easiest thing i could do actually and i didn't tried before. i simply left blank proxy host and port field and that solved my problem. Good luck!

And another resolution:

The way I was able to solve "The path provided by the UC_IMAGE_PATH environment variable may be invalid." issue.

  1. check if you have installed c:\glassfish3\pkg\python2.4-minimal or have c:\python27 installed.
  2. if python2.4-minimal is NOT installed, copy directory python27 to c:\glassfish3\pkg
  3. in the c:\glassfish3\pkg directory rename python27 to python2.4-minimal
  4. remove the UC_IMAGE_PATH environment variable by typing set UC_IMAGE_PATH= also remove the UC_IMAGE_PATH environment variable from your system start up.

As close as I can tell, if you already have Python installed, the Glassfish3 installation will NOT setup python2.4-minimal. when you go to the c:\glassfish3\bin directory and try to launch updatetool.exe, it is expecting the hard coded path name ..\pkg\python2.4-minimal\python.exe as relative to the c:\glassfish3\bin directory.

So there's a few things to try.

I'm gathering from all this that as Java sets up the Glassfish server it detects whether you have Python installed and if you do then it does not install it's own minimal Python as a dependancy. This means that if you remove Python then Glassfish breaks because they rather stupidly assume that you are always going to have Python installed.

Basically you wither need to reinstall Python, copy the files into the Glassfish directory, then uninstall Python or somehow get whatever installs Glassfish (maybe Netbeans?) to uninstall it or reinstall it with proper dependancies.

share|improve this answer
Thank you. That did the trick. – icu222much Apr 22 '12 at 16:03

Even though you copied the python27 folder into Glassfish and renamed it, you still can't run the updatetool becuase it needs something like

You can see the updatetool log file by entering updatetool.exe --debug, then you will know what I am referring to.

share|improve this answer

Program obviously asks you to install python. One can be found on Also make sure you install right version (one you uninstalled or better)so that it is compatible....

share|improve this answer
I don't need to use Python anymore. Is there anyway to disable this alert, or remove the its update tool? – icu222much Apr 21 '12 at 17:41

I after about two weeks after installing and running the glassfish server as an automatic startup service, AVG reported the installation of python.exe within glassfish has a virus. What pissed me off was that when I attempted to research the alleged virus, AVG decided (timed-out?) to quarantine python, then the auto-update 'feature' failed because it was gone. Since I'm only doing Servlets and JSPs in Tomcat, I simply opened the services, stopped glassfish, and set it's startup to manual. The aforementioned solution, by setting the environmental variable UC_IMAGE_PATH seems to be the popular solution. I'm not using it, but perhaps there's something on the Oracle site, if someone using it is so inclined to research...

share|improve this answer
Oh, I forgot, I did uninstall glassfish, and re-installed with the same results. The fact that it took awhile to manifest itself is somewhat curious. If it was running on Linux, I might attribute the delay to restarts, but running on Windows 7 (anything), a reboot is a daily requirement. I'm sure it's in some .NET manual or something... As my friend Tom Papaleo would say with regards to Windows, 'When in doubt, reboot!'. Who knows, unfortunately, AVG didn't tell me anything about the root cause. – Jeff Rancier Mar 3 '13 at 0:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .