Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently dealing with very large video files, including de/encoding them and copying them around etc.

To my surprise Windows attempts to cache these video files, even though there is no point in doing so. They're far too big to be cached. (Up to 230 Gigabyte.)

I am also shocked by the fact that Windows is almost completely clearing the normal contents of the cache for the video files. It is desperately trying to cache them, making my system pretty slow.

How can I tell Windows not to cache these files? If that is not possible, are there other ways to deal with this problem?

enter image description here

share|improve this question
    
How are they cached and how do you determine that they are cached? –  Oliver Salzburg Apr 21 '12 at 18:59
    
See minus.com/mbasREyoyB. They're mapped to memory by windows (maybe on request by VLC or VirtualDub)? –  robert Apr 21 '12 at 19:05
2  
Mysteries of Memory Management Revealed,with Mark Russinovich....channel9.msdn.com/Events/TechEd/NorthAmerica/2011/WCL405 –  Moab Apr 21 '12 at 20:37
2  
    
I have this problem whenever I perform backups of my virtual machines. Windows trashes everything I care about in the cache for one or two disk images I don't care about. It really does affect performance - it would be ideal if we could avoid caching specific files! –  Will Bickford Nov 8 '12 at 20:41
add comment

3 Answers

up vote 1 down vote accepted

Using Cacheset.exe from the Sysinternals Suite by MS solved the problem for me. Remember to run it as administrator, otherwise it will tell you that the values you entered are invalid.

Normally, caching the files should not be a problem, pushing other contents of the RAM out is. Check if you have the LargeSystemCache setting in HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management set. I suspect this is the real cause of the "clearing everything else" behavior. (My system was swapping out active processes while trying to cache a video I was encoding with avidemux).

share|improve this answer
    
I have checked my LargeSystemCache setting and it is 0. –  robert Jan 25 '13 at 11:26
add comment

I hope there are people still reading this. I have a PC based DVR app with 12 different TV tuners; which constantly records TV recordings (several simultaneous multi-GB recordings). It takes about 2-3 days when I start seeing this weird slowness. I can fix this by emptying file mappings from the standby list using RAMMap.

I'm unsure if if I can specify in Cacheset.exe the largest file size to map. I wouldn't want any more than a 758Mb file size to to use file mapping.

Here'a another URL with a person having the same issue as us: Windows: Disable caching of large files

share|improve this answer
    
Hi and Welcome to Super User! Please read the How to Answer a Question Guide. This site is a Q&A site not a forum. –  slm Apr 20 '13 at 4:35
add comment

I'm pretty sure what you're observing can't and shouldn't be disabled.

Every application can decide for itself to map a file into memory. And, to my understanding, that can drastically improve performance.

And, as you can see in your screenshot, the 4GB are already on Standby. Meaning they aren't actually any longer in use and can be re-assigned to new processes.

share|improve this answer
    
Windows cannot operate on mapped file data without caching it. It's smart enough to free those caches aggressively. –  David Schwartz Jan 24 '13 at 22:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.