Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to run a service interactively on my computer.
(I am already aware of the implications.)

How do I enable a service (running in session 0) to run interact with the current desktop in Windows 7?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

As of Windows Vista, there are no directly interactive services. "Allow service to interact with desktop" is basically just a legacy option, although if you use it UI0Detect should pop up and allow you to switch to a special desktop to interact with the service.

This article describes some options. If you have further questions, I suggest you ask at Stack Overflow as this is a programming problem.

share|improve this answer
    
Note that as of Windows 7, the UI0Detect service is not started by default. If you need to access legacy interactive services, you may wish to change the configuration for UI0Detect to start automatically. –  Harry Johnston Mar 25 at 0:48
add comment

As long as it is designed correctly, go under services.msc and check the box:

enter image description here

share|improve this answer
    
It says "Please enter a valid password". Also, wouldn't the privileges be pretty limited here? –  Mehrdad Apr 22 '12 at 2:47
    
Depends on what you are doing. . . What are you trying to do anyways? and what is the service? –  surfasb Apr 22 '12 at 8:23
    
It's a program I made for my own use. It needs system privileges, but like I said, that's a secondary worry. The primary worry is that this doesn't even work, since it's asking me for a password. –  Mehrdad Apr 22 '12 at 9:23
    
Services.msc is asking for a password? Select Local System account. Sorry, that SS is confusing I guess. –  surfasb Apr 22 '12 at 18:06
2  
"Allow service to interact with desktop" is a legacy option, as of Windows Vista it no longer works. –  Harry Johnston Apr 23 '12 at 5:47
show 5 more comments

I realize the original question was about a year ago, however it would be useful if more people are aware of how and why the question itself is incorrect.

You're confusing a service with an application; they are different beasts. What you actually want to do is create a separate application which you interact with and that exchanges information with your service.

Please read this article: http://asprosys.blogspot.com/2009/03/allow-service-to-interact-with-desktop.html

share|improve this answer
    
Welcome to Super User! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. –  slm Apr 25 '13 at 17:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.