Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using OS X Lion. I have a Vagrant box running CentOS 6.0 minimal on my mac. I am trying to install Oracle 10g on my CentOS 6. I keep getting an error

Can't connect to X11 window server

I have tried setting the DISPLAY variable to all the possible values; localhost, CentOS IP addr, Lion IP addr.. I just keep getting this error.

xclock doesn't work on CentOS (even as root). But xclock works fine on Lion.

How can I fix this error? Thanks

share|improve this question
up vote 2 down vote accepted

You installed CentOS minimal, so you don't have an X server running locally in the VM. If you want to try to install one, has some information about getting an X server set up (it's unfortunately easiest to simply set up one of the desktop environments).

You cannot use the X server in Lion for this directly from inside the VM, unless you enable insecure network connections. Better would be to ssh -Y into the VM from Lion; you can then run X11 programs from within that session with X11 forwarding to Lion's X server.

share|improve this answer
I have run yum groupinstall "X Window System" – y2p Apr 22 '12 at 4:46
Okay, if that didn't configure and launch a display manager, you will then need to run startx to actually launch it; then you can run the installer from within a terminal window. (Linux is not like OS X; there is no launchd configured to autostart X11.) – geekosaur Apr 22 '12 at 4:51
When I run startx, the terminal halts at expected keysym, got XF86TouchpadOff: line 121 of inet. And I have to run the Oracle installer from a different session. On running the installer I get Preparing to launch Oracle Universal Installer from /tmp/OraInstall2012-04-22_05-30-43AM. Please wait .....and it breaks and comes back to my prompt – y2p Apr 22 '12 at 5:32
That sounds like it has started X11 in a different virtual console but not switched you over to it for some reason (the "hang" is because the server is running in the foreground). Try switching consoles with Ctrl+Alt+Fn (that is, function keys F1, F2, etc.; X11 often starts on F7) until you find the one with the X11 session; the Oracle installer should have a window open there. – geekosaur Apr 22 '12 at 5:39
Does this work with Mac? I am on CentOS in terminal (no graphics). Alt+Fn opens OS X applications. Ctrl+Alt+Fn does not do anything. – y2p Apr 22 '12 at 5:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.