Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to remote log in to a PC using Remote Desktop Connection Client for Mac
enter image description here

The windows PC is configured in the system preferences to enable remote connection, but each time I attempt to connect using my Mac I get the same error.

enter image description here

Has anyone successfully used this?

-Update- enter image description here

the firewall is definitely disabled on the pc.

enter image description here

and remote login is definitely enabled.

any ideas?

CORRECTION This now works over the shared wireless network. If i test with the mac and pc connected to different wireless networks it does not work. What else needs to be appended to the IP address for the remote software can find the machine?

FINALLY http://www.whatsmyip.org/ use this link to get your EXTERNAL IP. this is what you need to use to accomplish this. Thank you so much everyone for your patience!!

share|improve this question
    
You sure there's no firewall in the way? Try disabling all firewalls first to check. –  Bob Apr 22 '12 at 16:49
    
Are they in the same LAN? –  bdecaf Apr 22 '12 at 19:18
    
they are right now, but overall they will not be. i will be using wifi to connect. –  jason m Apr 22 '12 at 19:26
    
Does RDC work win you do Win->Win? –  Scott Chamberlain Apr 22 '12 at 19:46
    
@jasonm: Why would you filter a local IP? You would be better of filtering your computer name from the other image because it gives a lot away if you feel targeted, in case you would like to do so flag the post for a moderator (because we can still see older edits). –  Tom Wijsman Apr 22 '12 at 21:27
show 3 more comments

1 Answer

up vote 1 down vote accepted

The default port that the Windows Remote Desktop Client uses is 3389. So, first, when you attempt to connect, add that port to the IP address. 192.168.x.x:3389

As has been mentioned, make sure the Windows Firewall is set to allow RDC connections and/or connections on port 3389. Check to ensure there is no firewall installed on the Mac that is blocking activity on 3389.

Check your router as well. Feel free to forward all traffic on port 3389 to the specific IP address of the Windows PC. Go that extra step and assign a static internal IP address to the Windows PC MAC address in the reserved DHCP table.

share|improve this answer
    
thanks i tried the 3389 but i am still getting the same issue. do i need to be logged off on the windows machine i am trying to connect to from the mac? –  jason m Apr 22 '12 at 19:02
    
@jasonm: No, RDP will by default automatically log off the current user. –  Tom Wijsman Apr 22 '12 at 21:29
    
@jasonm you say that this works over shared wireless, but not over different wireless networks. What exactly do you mean by that? Do you mean two wireless routers connected via an ethernet cable? Or do you mean if you leave the house and try to RDC into the computer, you can't? If you mean that you are trying to connect from outside of your shared LAN, then you need to do three things. You need to make sure the Win PC has a static internal IP. You need to have port 3389 forwarded to that IP at the router, and you need to connect to your EXTERNAL IP address with the Mac. –  Bon Gart Apr 23 '12 at 2:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.