Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I start my notebook, it fails to connect to any wireless access points. I can still view available wireless networks and attempt to connect to them - but it always fails.

The only thing that seems to work is to visit Network and Sharing Center and click Troubleshoot Problems. After running through the troubleshooting wizard, the wireless network adapter gets reset and everything works perfectly after that.

enter image description here

I have made sure that Windows is using the newest driver available for the adapter and I also tried the driver that shipped with the notebook and the latest driver from Intel. All of them exhibit the same behavior.

Here are some pertinent messages from the event viewer:

The Network Connected Devices Auto-Setup service entered the stopped state.
Details about network adapter diagnosis: Network adapter Wi-Fi driver information: Description . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN Manufacturer . . . . . . . . . : Intel Corporation Provider . . . . . . . . . . . : Microsoft Version . . . . . . . . . . . : Inf File Name . . . . . . . . . : C:\Windows\INF\netwlv64.inf Inf File Date . . . . . . . . . : Saturday, February 18, 2012 12:00:37 AM Section Name . . . . . . . . . : Install_MPCIEX_GEN_4965_AGN_VISTA64_MOW1 Hardware ID . . . . . . . . . . : pci\ven_8086&dev_4229&subsys_11008086 Instance Status Flags . . . . . : 0x180200a Device Manager Status Code . . : 0 IfType . . . . . . . . . . . . : 71 Physical Media Type . . . . . . : 9
The Network Diagnostics Framework has completed the diagnosis phase of operation. The following repair option was offered: Helper Class Name: NdisHC Root Cause: There might be a problem with the driver for the Wi-Fi adapter Windows couldn't automatically bind the IP protocol stack to the network adapter. Root Cause Guid: {46ec1e49-ca70-4561-9ab7-009f6b1b3709} Repair option: Set up the wireless network adapter Set up the network adapter to communicate with this network. This ensures that both Internet Protocol Version 4 (TCP/IPv4) and Internet Protocol Version 6 (TCP/IPv6) can be used on the network adapter. RepairGuid: {4406f2cc-9cbd-4098-a03a-e5c9810e4895} Seconds required for repair: 70 Security context required for repair: 37
The Network Diagnostics Framework has completed the repair phase of operation. The following repair option or work-around was executed: Helper Class Name: NdisHC Repair option: Set up the wireless network adapter Set up the network adapter to communicate with this network. This ensures that both Internet Protocol Version 4 (TCP/IPv4) and Internet Protocol Version 6 (TCP/IPv6) can be used on the network adapter. RepairGuid: {4406f2cc-9cbd-4098-a03a-e5c9810e4895} The repair option appears to have successfully fixed the diagnosed problem.

Note: this problem is very similar (but different) from one I had earlier with my wired network adapter.

share|improve this question
Did you download the latest driver from Intel?… – Moab Apr 22 '12 at 18:45
I think it is pointless to troubleshoot this problem when you are using a beta OS and drivers that were not meant to be used on that OS. Way too many variables... – Logman Apr 22 '12 at 19:57
@Moab: Oh, yeah - I forgot to mention that I tried the drivers from Intel's website - same results. – Nathan Osman Apr 22 '12 at 20:09
Could you also add to your post the outputs of "ipconfig /all" from (1) when the problem exists, and (2) after the problem is fixed. – harrymc Apr 28 '12 at 16:02
@GeorgeEdison: You had better answer our questions if you wish to get useful answers. – harrymc Apr 30 '12 at 7:16

You're using Windows 8 preview, so it could very well be some issue with the driver not working under this new, unfinished OS. It's not that uncommon.

share|improve this answer
Not true, has occured in Windows 7 as well. And your link doesn't refer to this. – Tom Wijsman May 31 '12 at 16:45
@Tom, the OP's question is about Windows 8 preview. If you're having problems with something in Windows 7, ask a new question, because the troubleshooting steps and the solutions are going to be different. To guard against having your question closed as a duplicate, reference this question in your question and point out that this question refers to Windows 8 preview which is not a release version and therefore drivers are not necessarily expected to work while Windows 7 is a production version which the current drivers should support. – Old Pro May 31 '12 at 17:59
Doesn't change the fact that this the OS version is irrelevant. Drivers do work, else I wouldn't comment here. You just gave him a standard moot response. The troubleshooting steps and solutions are not different at all because the code is re-used and thus is still the same. I won't start a new question if I'm experiencing the exact same as the OP. Furthermore, I'm actually making progress, found the root cause through logging and debugging and will provide updates through this Q&A later on. This bug affects 4965 AGN (which I had in Windows 7) and 5100 AGN (which I have in Windows 8) mostly... – Tom Wijsman May 31 '12 at 22:08
@Tom, OS version is relevant because Intel provides a 4965AGN driver for Windows 7, and if that doesn't work in Windows 7, that is a bug that Intel should fix. At the time the OP asked, Intel was not publicly providing a driver they claimed would work with Windows 8 preview, so if the Windows 7 driver didn't work, so what? The link explains that "you might also encounter errors that you wouldn't encounter using a released version of Windows" and "You might also encounter problems like... printers, video cards, or other hardware that doesn’t work." OP's problem is not unexpected. – Old Pro May 31 '12 at 22:27
I'll just keep it at "We're here to solve problems.", your answer doesn't so hence my comment. EOF – Tom Wijsman May 31 '12 at 22:48

What is the lease period for the network you are joining? This could happen if the leases are being issued for unusually small windows. So if the lease was only issued for 60 minutes and you reboot after 61 minutes the wireless manager could view the lease as expired and move on to the next available network in your list. Typically on my local networks I set lease periods for 7 days to keep this from happening.

First you should check your wireless networks by going to network and sharing center, manage wireless networks and make sure that the network you want to join is listed and that the networks you've joined are in the correct order.

When you "troubleshoot" the connection it is simply renewing your machines IP address on the network. You can see what is occurring the next time this happens by opening powershell or a command prompt and typing:

ipconfig /all

Look at the wireless adapter and see when the lease was obtained and when it expires. If it expired in the past then this may be your issue. type:

ipconfig /release

ipconfig /flushdns

ipconfig /renew

Your network should obtain a new lease. Once your connection is up connect to the device that is issuing your IP addresses. You can typically access your DHCP server, which is typically your Gateway, by opening a browser and navigating to its IP. Once you connect change the lease period to a higher value. Most commonly this is set to 18-24 hours but as I said, I raise mine in my environments.

Post back if this doesn't work and we can look at other options.

share|improve this answer
My wireless adapter doesn't even show up in ipconfig /all. – Nathan Osman Apr 22 '12 at 21:17
@GeorgeEdison: Is your Wireless Apdapter enabled at that point (both physically [by some button or however your laptop / PC support it] and in Network Connections)? – Tom Wijsman Apr 22 '12 at 21:59
@TomWijsman: Yes - both are enabled. In Network Connections, it says "enabled" next to the Wifi adapter even though it doesn't connect to anything :P – Nathan Osman Apr 22 '12 at 22:28
These "standard" commands don't do a thing... – Tom Wijsman May 31 '12 at 16:46

Most laptops I've seen have a button on the keyboard for enabling/disabling wireless so you don't have to do it through your OS. If disabling/enabling resolves the problem, I'd be inclined to just use that button if you have one (out of some amount of laziness and lack of desire to waste my time on what is more than likely a driver bug).

share|improve this answer
I'm afraid toggling the switch doesn't resolve the problem. – Nathan Osman Apr 27 '12 at 22:05
The switch is always on here. Eg. I do not need to toggle it to resolve the issue. – Tom Wijsman May 31 '12 at 16:48

make sure to check the device manager, there is often an option under the properties of the specific device to " turn off device to save power"

This option will turn the network device off during sleep etc and can have problems when the machine fires up, seen it multiple times. Check that option and let me know

share|improve this answer
Old Pro has a valid point also. – Luke Russell May 2 '12 at 16:33
Also settings within - Control Panel/Power Options/Change active Plan Settings/Change advanced power settings/Wireless Adaptor Settings/Power Saving Mode change to 'Maximum Performance', it is my understanding that the Adaptor will never attempt to go into power-saving mode. – HaydnWVN May 3 '12 at 10:26
I'm afraid that doesn't seem to make any difference. – Nathan Osman May 3 '12 at 20:29
Tried this, doesn't change anything about it. – Tom Wijsman May 31 '12 at 16:49

I fixed mine by removing the check mark next to "Deterministic Network Enhancer" from the properties of my card:

enter image description here

I'm pretty sure it was from a Cisco VPN install I did a while back and have long since removed. The network card was working fine for months but suddenly it just started needing repair after every reboot. I just fixed it so I'll let you know if it continues to hold.

share|improve this answer

Sometimes additional tools to manage the wireles networks collide, like Lenovos "Access Connections" and Windows' own WLAN (and like fixed IP) control.

I had some issues having a fixed IP assigned in my interface settings (windows) and wanted to do some DHCP with the Lenovo tool...

So check what tool to use for managing your wireless networks.

share|improve this answer
I don't have any other tools - this is a completely clean install of Windows 8 from scratch. – Nathan Osman May 2 '12 at 19:40
Same here, no additional tools. – Tom Wijsman May 31 '12 at 16:47

You may have an incompatible network protocol or filter

3rd party firewalls and vpn client software have been reported as causing this problem.

Check the Connection Properties for your wireless adapter and disable any interesting filters or protocol stacks.

enter image description here

share|improve this answer
I only have IPv4 enabled, this doesn't work. :( – Tom Wijsman May 31 '12 at 16:47

You must log in to answer this question.

protected by Community Apr 18 '13 at 21:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .