Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run VMware Player on CentOS 6. I am stuck with the following issue after installing the VMware Player package. VMware Player fails to start and gives the following error message.

Virtual machine monitor [FAILED]

While trying to query the status of VMware Player, the following does not load

Module vmmon not loaded

I am at my wits end after trying to resolve this. Please let me know your suggestions and advice. Your help is very much appreciated.

This question has been closed on both the stackoverflow and serverfault sites saying "Off Topic". I hope this is the place to ask.

share|improve this question
add comment

1 Answer

Please check on the following to resolve the issue.

  • Make sure your kenel-headers is installed matching to your running kernel.
  • Remove the old binary modules: mv /usr/lib/vmware/modules/binary /usr/lib/vmware/modules/binary.old

  • Rebuild it again: vmware-modconfig –console –install-all

    Chakri -

share|improve this answer
    
tried matching # rpm -q kernel-devel kernel-devel-2.6.32-220.13.1.el6.x86_64 # rpm -q kernel-headers kernel-headers-2.6.32-220.13.1.el6.x86_64 # uname -r 2.6.32-220.13.1.el6.x86_64 –  zapping Apr 24 '12 at 5:13
    
when vmware-modconfig –console –install-all is done it completes a build but the virtual monitor still fails to load. –  zapping Apr 24 '12 at 5:17
    
tried #service vmware status Module vmmon not loaded Module vmnet loaded –  zapping Apr 24 '12 at 5:18
    
When i try this the output is an error # modprobe vmmon FATAL: Error inserting vmmon (/lib/modules/2.6.32-220.13.1.el6.x86_64/misc/vmmon.ko): Invalid module format –  zapping Apr 24 '12 at 6:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.