Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got a Linksys gateway WAG54G2 and there is a problem, that I can't find in the gateway web-configuration how to set static IP for my PC using cable connection. Firmware Version:V1.00.10

share|improve this question
up vote 2 down vote accepted

Most Linksys firmwares do not allow you to set static IPs from the router. You can only do it on the PC itself with manual networking settings.

Most Windows PCs can use Control Panel to get to network settings (example: "Network and Dialup Connections" then "Local Area Connection" then "Properties"). Navigate to the settings for "TCP/IP" (example: "Internet Protocol (TCP/IP)").

Change from "Obtain an IP address automatically" to "Use the following IP address". Enter these values (all are important and exact wording may vary):

  • IP address: 192.168.1.# (find out from router subnet mask)
  • Subnet Mask:
  • Default Gateway:
  • DNS servers: (find out from router)

alt text

share|improve this answer
I tried this, and it works. For one time. After restart it ALWAYS doesn't work at all. I tried setting DNS to gataway IP, to proper IP, and no IP, all of that is working only till I restart my computer :( – Thinker Oct 16 '09 at 10:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.