Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using windows XP SP2 and SQL Server 2000. I can successfully connect to a database from the host computer via and also with the local IP (which is

But when when I try to connect to that database from another PC via, it doesn't work.

  • I tried to allow ports in the firewall and it still didn't work. I also tried turning the firewall off and it still didn't work.

  • I can ping successfully from other computers.

  • I tried WampServer which worked.

  • I also did some TCP/IP settings which Microsoft asked me to do and it still didn't work.

I think it has something to do with SQL Server permission and/or the listening IP, since the error message says that the database does not exist or that access is denied (but I know that the database exists).

How should I continue my error searching process?

share|improve this question

migrated from stackoverflow.com Apr 23 '12 at 11:57

This question came from our site for professional and enthusiast programmers.

Are you trying to connect from SQL Server Enterprise manager/ Query Analyser or any .NET application? –  Thakur Apr 23 '12 at 7:17
Did you enable the TCP/IP in the "SQL Server Configuration Manager"? –  mrab Apr 23 '12 at 7:23
in the database... who is allowed to connect? I don't know how it is in MSSQL but in mySQL you have to explicitly set the user and database to accept connections from other IP addresses. –  DemonWareXT Apr 23 '12 at 8:08
I am trying to connect SQL Server. I want to connect to a specific database. And yes I did enable TCP/IP in SQL Server Configuration Manager. I allowed two users to connect to the database that is "sa" and "acclogin" but I have no idea about the IP thing you are talking about. –  Richie Apr 23 '12 at 12:10
Well normally you have to allow users to connect from outside the server. Might help: bodhost.com/forum/windows-dedicated-server/… –  DemonWareXT Apr 23 '12 at 14:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.