Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a possibility to add a custom shortcut containing the super key.

For example I add "gnome-terminal" as a custom shortcut and want to apply "Super+t". This is also shown, but doesn't work. (see GNOME bugzilla)

I read, that you have to replace "Super" with "Mod4" but I doesn't found the location of this setting in dconf.

Any ideas?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I had this same problem after upgrading. The dconf path is org/gnome/settings-daemon/plugins/media-keys. The predefined shortcuts live there. Custom shortcuts live further down under custom-keybindings/custom0 (or custom1, and so on).

Changing <Super> to <Mod4> in my shortcuts fixed the problem.

share|improve this answer
4  
Thanks! Now I have to hold Super and press "t" twice. After the first "t" the letter t appears (i.e. in the current window) and then the shortcuts is executed. Any workaroungs? –  kabum Apr 25 '12 at 12:01
    
Sorry, I'm not sure. I don't have that problem. –  Evan Shaw Apr 25 '12 at 22:09
    
How do you change it? not all shortcuts appear in gconf-tool/dconf-editor (as gnome3 now have 200 places for configs)... i can't type anything in the shortcuts editor window... changing the layout options so that Win key is Meta/Hyper etc has no effect on the shortcuts window as it will always show Super for the Win key. –  gcb Jun 10 '12 at 19:16

This gnome-shell bug report both outlines the problem with Super+Key shortcuts, and details a hacky workaround (which completely fixes the problem for me!):

https://bugzilla.gnome.org/show_bug.cgi?id=659899

Basically, the issue is that custom shortcuts are handled by gnome-settings-daemon, which does not pick up the Super key properly. The window manager (in this case, mutter) can see the Super key. So, Olivier Crete wrote an extension that reads your custom shortcut definitions and passes them up to mutter. I installed the extension and it works great for me. No double key pressing needed like some of the previous commenters were talking about.

The extension is not in the official gnome extensions site because it was rejected (you can read the hilarious reviews over here: https://extensions.gnome.org/review/1658 ... apparently the reviewers are having problems with reading comprehension!). However, you can download the extension via comment 33 in the bug report.

Unzip the file to your ~/.local/share/gnome-shell/extensions directory, restart gnome-shell (Alt+F2, r), and fire up Gnome Tweak Tool and enable the extension. You should then be good to go.

EDIT: One more thing. If you have more than 6 custom shortcuts and activate this extension, gnome shell will explode. The extension hard codes in support for 10 shortcuts, but only compiled support for 6. To add support for an arbitrary number of shortcuts, in the schemas directory edit the org.gnome.shell.extensions.command-keybindings.gschema.xml file and copy/paste more binding entires (it should be self evident how to do that- just make sure to increment the binding-#). Then, in the schemas directory run "glib-compile-schemas ." Finally, in the extension.js file, find the "for (let i = 0; i < 10; i++)" line and change 10 to the number of total bindings you set. Now you should have support for lots more custom shortcuts. Phew! No one said Gnome 3 was easy! Oh, wait...

share|improve this answer

Have had the same problem under Debian Wheezy, and changed "Super" to "Mod4" under dconf. Old shortcuts are coming back, but it's still pretty annoying to press the character keys twice.

Thanks anyhow! Hope they'll fix it soon...

share|improve this answer
2  
AHH - just found a solution at ubuntuusers!! Just change the keyboard settings - link on the bottom - options. Then behaviour of Win/Alt-Keys and Hyper is bound to Win-Keys. Note: the activities overview now only works with Alt-F1. –  JHuber Sep 29 '12 at 15:25
    
please convert your comment to the answer, it is valuable –  pihentagy Feb 26 '13 at 9:55
    
This is a re-write of JHuber's comment since it was difficult for me to figure out. In gnome3, run "Keyboard" under Settings. Then click "Layout Settings" (link at the bottom). Then click the options button. Then expand the + for Alt/Win key behavior" and change the setting to "Hyper is mapped to Win-Keys". This does prevent having to type the shortcut key twice, but prevents the Super key from bringing up the overview (like clicking Activities). –  Chad Skeeters Jul 9 '13 at 14:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.