Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About to lose my mind on this one. I'm trying to install Xapian on an Ubuntu 11.04 box. All the docs say that I need to install the xapian-core package, but apt-get can't find it. I even installed the Xapian backports ppa, and still no xapian-core package. Anyone know what's up here? Forgot to mention that yes, I have ran sudo apt-get update both before and after installing the xapian ppa.

share|improve this question

3 Answers 3

Debian (and thus Ubuntu) does not seem to have a package called "xapian-core" as you have noticed (at least not in every available version). Looking at http://packages.debian.org/sv/source/sid/xapian-core, it seems that the upstream source package named xapian-core is used to build the Debian packages:

  • libxapian-dev
  • libxapian22
  • libxapian22-dbg
  • xapian-doc
  • xapian-examples
  • xapian-tools

, so installing that bunch should be equivalent to what upstream calls "install xapian-core".

If you are on an older Ubuntu revision, you might only have libxapian15/libxapian15-dbg, but it should be similar in other respects.

(Usually a splitting of upstream like this implies the existence of a meta package that would install all of the above, but it doesn't seem to exist.)

share|improve this answer
    
Beat me to it, so upvoted :) You can see the exact details of the elements of this group package for Natty (11.04) here: ubuntuupdates.org/package/core/natty/main/base/xapian-core –  Adam C Apr 23 '12 at 15:07
    
Well perhaps it's outside the bounds of this question, but the python app I'm dealing with can't locate Xapian still after installing all those packages above (actually had already tried that). Based on the package descriptions, none of those actually contain the Xapian "core", as in the actual meat. They're just helpers or tools required for compiling bindings. I should mention that I also have installed the python-xapian package. –  Chris Pratt Apr 23 '12 at 15:21
    
@ChrisPratt: libxapian22 sounds like the "meat" to me. Perhaps one has to specify the library paths for Xapian to the Python app? –  Daniel Andersson Apr 23 '12 at 16:39

You can find all of the available xapian packages for Natty (11.04) at: http://packages.ubuntu.com/natty/allpackages

share|improve this answer
$ sudo apt-get install libxapian-dev libxapian22 libxapian22-dbg xapian-doc xapian-examples xapian-tools python-xapian 

Additionally, see the http://packages.ubuntu.com/source/raring/xapian-bindings for the full list of xapian bindings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.