Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm just bored clicking on the CONTINUE button every time "You'll need to provide administrator permission" prompt appears, as I'm the only administrator of the PC. I've configured Notification system to 'Never Notify' from Control Panel -> UAC but still no luck.
I've to face the problem when copying / moving / renaming file on an additional internal disk.

share|improve this question
Give the require rights to perform the action on the user you are using. – Ramhound Apr 23 '12 at 16:17

4 Answers 4

You could take ownership of the internal folder you use.

share|improve this answer

I also had to figure it out and I thought I would share the answer:

  1. Go to windows explorer
  2. Right mouse the drive in question
  3. Go to properties
  4. Select security tab.
  5. Change permissions to full
share|improve this answer

You are not allowed to take ownership of many files like C:\Users, C:\bootmgr, C:\hiberfile.sys, pagefile.sys, C:\Program Files, etc., and thereby even the C:\ drive as a whole. Also, setting permissions isn't disabling the admin prompt, it's simply attempting to sidestep the issue instead.

Here is the actual solution: Disabling the prompt

For Windows 7 Ultimate, Business or Enterprise edition which has Local Group Policy, or computer joined to domain and has Active Directory-based GPO, the group policy can be used to disable UAC for local computer or many computer across large networks at once.

  1. Enter GPedit.msc in Start Search to run Local Group Policy editor. (Or gpmc.msc to run Group Policy Management Console for AD-based domain GPO editor).
  2. Navigate to the following tree branch:

    Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options

    In GPMC, browse to the required GPO which is linked to the domain or OU where the policy wants to apply.

  3. Locate the following policy in the right pane:

    User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode

  4. Set its value to Elevate without prompt.

  5. Locate the following policy in the right pane:

    User Account Control: Detect application installations and prompt for elevation

  6. Set its value to Disabled.

  7. Locate the following policy in the right pane:

    User Account Control: Run all administrators in Admin Approval Mode

  8. Set its value to Disabled.

  9. Locate the following policy in the right pane:

    User Account Control: Only elevate UIAccess applications that are installed in secure locations

  10. Set its value to Disabled.

  11. Disable UAC with Group Policy

  12. Restart the computer when done.

share|improve this answer

According to this article there may be some issues with Metro apps, but disabling UAC using regedit worked for me. To do so, start regedit (by typing regedit in the run command) and navigate to:


Change the value of the entry EnableLUA to 0. Then restart your machine. Upon doing this, I never get nagged with a dialog to "provide administrator permission" anymore.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.