Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am experiencing a very annoying problem with FireFox 11.0 on Windows XP SP3, and unfortunately it is making it very difficult to use one of my favorite sites!!!

This problem appeared several weeks ago. Anytime I navigate to a Stack Exchange site (i.e. this site, SuperUser, but also StackOverflow, ServerFault, etc.) I am presented with 5 - 10 of the following pop-ups - on every page:


A few things to note:

  1. This pop-up does not prevent me from viewing the page. It is just very annoying. I can enter in my username / password to no effect, but I also can click cancel repeatedly. After about 10 tries, I finally can read the page (but have to start over on the next page I view).

  2. This problem doesn't occur in IE.

  3. This problem does not occur with any other web sites, just StackExchange sites. Why?

  4. When I do enter my AD user / password, FireFox pops up the "do you want to remember this username / password?" popup (see here), but is immediately dismissed by the "moz-proxy" pop-up.

  5. I am not using (nor do I want to use) any sort of proxy add-on like FoxyProxy.

Please help as I want to be able to use my favorite developer site whilst at work again :(

share|improve this question
Do you experience this issue when you use Firefox Safe Mode or with a new Firefox profile? – iglvzx Apr 23 '12 at 23:46
After some Googling, it looks a lot like your cache is being password. Try a cache clear first to see if that changes anything, then try safe mode/new profile like @iglvzx suggested. – digitxp Apr 23 '12 at 23:51
it's a problem with your firewall & WebSockets. Chrome handles this situation better. Posts on Meta Stack Exchange - My corporate proxy doesn't support web sockets, which makes SE a pain to use Getting authentication prompt for on every page load? – Sathya Apr 24 '12 at 4:22
up vote 5 down vote accepted

In order to make the dialog disappear, I had to switch from "Use system proxy settings" to "Manual proxy configuration", copy proxy settings from IE, and add '' to 'No proxy for' field.

Another option is to install 'BlockSite' add on and add '' to the blacklist.

share|improve this answer
"add '' to 'No proxy for' field" - either this worked, or simply using "Manual proxy configuration" did the trick. Either way, problem solved! – noahz May 1 '12 at 21:25
I already had manual proxy configuration, but was still experiencing the issue. Adding sockets.ny to no-proxy field fixed it. – eis Sep 4 '12 at 6:48
In addition, I had to check "Use this proxy server for all protocols". Then this fix worked. – lrussell Nov 5 '12 at 10:40

The most likely explanation is that the proxy server you use permits the stack sites, but doesn't permit some of the third party elements that make up a page, such as adverts and any other external resources.

Each one of these that is blocked returns a permission denied to Firefox, which causes firefox to prompt you for different credentials to access the blocked content. IE doesn't do this, if it gets a permissioned denied from the proxy server, it silently drops the content (you will sometimes see your proxy server "blocked" message appearing in the middle of pages where this has happened in IE).

To test this, look through the source of a page in ff, and search for any instances of http:// then try each of these URLs in IE to see if you get a proxy blocked message.

If you do, you can stop these URLs being presented to the proxy by putting them in your c:\windows\system32\drivers\etc\hosts file:
share|improve this answer
websockets, it in this case. Check for my comments in question – Sathya Apr 24 '12 at 4:48
@Sathya I see. So would blocking SE websockets stop the site working, or it still usable (ie, would this approach of directing to localhost work)? – Paul Apr 24 '12 at 5:17
it'll be usable, just no realtime updates of votes – Sathya Apr 24 '12 at 5:33
Alas, adding '' to my hosts file didn't work. – noahz Apr 24 '12 at 21:35
@noahz That is the most likely candidate apparently, but there may be others. You'll need to go through the urls that make up the page to see, or ask your proxy admin for a list of the urls that get blocked when you access the site. – Paul Apr 24 '12 at 23:42

Are you using FoxyProxy?

I was and it was the culprit. Seems that FoxyProxy does not like websockets.

Just for a quick test, disable FoxyProxy by going to the FoxyProxy icon, right click on it and select "Completely disable FoxyProxy".

share|improve this answer
Nope, not using FoxyProxy – noahz May 1 '12 at 12:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .