I (among other things) manage an older debian Lenny server - and now have a need to update PHP from version 5.2 to 5.3 (we currently have 5.2.26 installed). This is required to support some of the functionality that 5.2 doesn't support, specifically sqlite3.
I've found several sites on the internet dealing with this issue, but they all seem to be outdated and the files they refer to seem to no longer exist. Trying to make changes to the instructions on teh fly is not easy - and this is made even more difficult by the fact that php versions keep moving up and now seem to require a lot of newer versions of other libraries.
I'm in an even worse situation because the server is a live production website that serves client all over the world (Australia, Europe, North America), so I don't have the luxury of a night to sort this out. The best I can do is bring it down for an hour to do upgrade and quickly re-test the site. I know the site will work with the new version, because development server apparently has newer version installed (I don't manage that one).
As much as possible, I would like to avoid compiling php from sources. I remember doing something similar some time ago on another server. At that time, the version was 5.3.10~dotdeb.0 - but now I can't find that version any more. I downloaded the .deb packages for pretty much what I need (they are version 5.3.10~dotdeb.1) - but they won't install complaining of unmet dependencies on libreadline6, libonig2 and so on. Checking against that other server, the requirements were libreadlin5 - so it looks like in going from 5.3.10~dotdeb.0 to 5.3.10~dotdeb.1 the dependencies were upgraded as well.
I'm stuck now, so any help is extremely appreciated.